Honda / Acura K20a K24a Engine Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
68 Posts
Discussion Starter · #1 ·
Hello,

I've got an EK swapped k20a3 (SiR version) car with a KMOD vtec killer setup (link).

Other mods:
Skunk TB
Skunk IM
Hybrid CAI
IACV Blockoff
PCV blockoff
Header
Exhaust

All of the standard bolt-ons basically.

I'm having trouble with the idle, it wants to stall (RPMs seem too low when idling). I can increase the RPM in Kpro but the car still runs like shit from 1-2 gear.

I figured I would post this here and see if anyone has previous experience tuning a car with a "vtec killer" setup.

Ideally I'd like to a buy a decent .kal from someone that will at least allow me to make the car more drivable so that I can get it to a shop for a tune. I'm way too much of a noob with this stuff unfortunately. Any help would be much appreciated.
 

·
Registered
Joined
·
68 Posts
Discussion Starter · #3 ·
@LotusElise is a skilled tuner. He may be able to send you something. How far is the tuner from you? Maybe a u haul trailer rental would be a solution ?
Thanks, I'll send him a message.

The tuner is a good 40 minute drive from me. Bit of a pain transporting the car that way, but may be the only solution.
I'll keep searching in the meantime and look for tuning suggestions that I can try myself too.
 

·
Registered
Joined
·
750 Posts
as the car runs on MAP as a control strategy and you'll have a very high idle MAP, this is normal. Speed density on hot cams sucks.
What can you do? Increase idle rpm to like 1.5k.
Or switch to alpha-n using TPS as a load indicator. KPro can do this, but it is not working that well. Alpha-n works best with ITBs, but a plenum is OK, too. Give it a shot.

Your sk2 TB also does not help as these bigger aftermarket TBs let a lot of air pass at already very low throttle openings leading to poor throttle control. On hot cams this comes close to an on-off switch at low rpm. It is also common to see ambient MAP from as litte as 50-60% TPS. Essentially the TB is too big and the last third of the opening has no significant influence on gas flow anymore.
 

·
Registered
Joined
·
68 Posts
Discussion Starter · #5 ·
as the car runs on MAP as a control strategy and you'll have a very high idle MAP, this is normal. Speed density on hot cams sucks.
What can you do? Increase idle rpm to like 1.5k.
Or switch to alpha-n using TPS as a load indicator. KPro can do this, but it is not working that well. Alpha-n works best with ITBs, but a plenum is OK, too. Give it a shot.

Your sk2 TB also does not help as these bigger aftermarket TBs let a lot of air pass at already very low throttle openings leading to poor throttle control. On hot cams this comes close to an on-off switch at low rpm. It is also common to see ambient MAP from as litte as 50-60% TPS. Essentially the TB is too big and the last third of the opening has no significant influence on gas flow anymore.
I will try setting the RPM to 1.5k then and see if that helps.

You're probably correct about the TB not helping things... I did only go with the 70mm but still slightly larger than stock. Probably not an ideal build setup, but I just wanted to have some fun with the a3 before swapping it lol. I'll try your suggestions and see if anything helps!

Thank you for your insight. 🙏
 
1 - 5 of 5 Posts
Top