Honda / Acura K20a K24a Engine Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1,202 Posts
Discussion Starter #1
1992 cx hatchback...

ok I've got another wiring problem, when I turn my parking lights (corners) on...
-the drivers side lights up but the passenger does not

...but when I put my directional on the...
-drivers side does nothing
-Passenger side blinks

When I turn my hazards on...
-both blink

any clue as to what the deal is? Tail lights work fine, its just the corners with the problem

-the horn does not work either


also, the car has no engine harness as I'm prepping it for my K, i was just wondering if when I turn they key 2 clicks am I supposed to hear the fuel pump prime? Or will it not prime without an engine harness in there to ground it?
 

·
Registered
Joined
·
6,415 Posts
You're going to need to review your turn signal wiring using some type of service manual. If I remember right they should work properly even with no engine in the car...

The fuel pump won't prime without an engine harness and ECU.

Hope that helps. :up:
 

·
Registered
Joined
·
1,202 Posts
Discussion Starter #3
what if I had the stock d-series p05 ecu plugged in? it wont prime with that either... so does it need the engine harness in there aswell to ground the fuel pump wiring correctly so that it will prime?

just looking for an educated answer, as I've gotten many different answers...
 

·
Registered
Joined
·
616 Posts
yes you need the engine harness ground for the computer to be able to have the fuel pump prime,
 

·
Registered
Joined
·
1,202 Posts
Discussion Starter #5
ok, so thats cleared up. So I'm no longer worried about the pump not priming in the cars current state.... any idea on the directionals
 

·
Registered
Joined
·
183 Posts
The stalk could be faulty or a relay (is there a relay in that system).

best bet, consult a wiring diagram or manual for your specific care (year, make and model)
 
1 - 7 of 7 Posts
Top