Honda / Acura K20a K24a Engine Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I drive an 05 accord 2.4L auto VTI-EX. I noticed a while ago that my engine had lost compression and was losing oil a lot so I decided to throw in a new motor.

I purchased a new engine but later got to find out it was a K24A6 engine variant instead of a K24A4 like my last engine.

Now the car is having a permanent check engine light, scanned and got codes P0341 (camshaft position sensor A) and P0747 (Pressure control solenoid A stuck on).
It drives and isles different and erratically. If I switch on the air conditioning it vibrates so badly the entire car shakes or just stalls the engine.

I just want to know more about this engine as it’s past it’s warranty and I can’t return to the shop I purchased it from for an exchange.
Has anyone come across this variant of K24 engines before?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
135 Posts
From what I can find a K24a6 should be the same as a K24a4. Are you sure you plugged in both camshaft position sensors? And did you reuse your old sensors or did the new engine come with them?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
From what I can find a K24a6 should be the same as a K24a4. Are you sure you plugged in both camshaft position sensors? And did you reuse your old sensors or did the new engine come with them?
I reused the ones from my old engine and had two same I same issue, bought new ones and same thing.

Ii checked the timing and it is on point too. Now i am suspecting the timing chain tensioner might need replacement or a bad iacv. The main issue bothering me is the way the engine vibrates and bogs down when I switch on the AC with the gear in D and my foot on the brakes. Without ac my idle RPM is steady on 650-700 but once I switched on the AC it drops and holds at 500 RPM.




Sent from my iPhone using Tapatalk
 
1 - 3 of 3 Posts
Top