Honda / Acura K20a K24a Engine Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #1 ·
i was wondering what problems to expect when doin a k20 eg swap. ones i know of are the heater hoses, cut out the bulkhead for shift shit, exhaust and header, and fuel stuff. any input will be appreciated. thanks :up:
 

·
Resident Journalist
Joined
·
501 Posts
i think most people run into the problem of aligning their mounts into the chassis bracket... just be patient, if somethign doesnt work out, dont quit, haha you got ot move the motor around a bit till it fits in perfectly.
 

·
Premium Member
Joined
·
1,550 Posts
bmxbrad521 said:
i was wondering what problems to expect when doin a k20 eg swap. ones i know of are the heater hoses, cut out the bulkhead for shift shit, exhaust and header, and fuel stuff. any input will be appreciated. thanks :up:
not really a problem, but expect to have a fluctuating idle when you first get the engine running. Bleed the cooling system for about 20min by leaving the cap off the radiator to let the air bubbles escape, then go drive the vehicle around for about 30min, the ecu will do its fuzzy logic routine and adjust the idle. The key in getting rid of the fluctuating idle (if you dont have any vaccum leaks) is driving around for more than 20min so the ECU can learn the motor.

I speak from my experience with a KPRO, not sure if the fluctuating issues occur with a JDM K20 ecu.
 

·
Punishin' Bitches
Joined
·
2,453 Posts
katman said:
not really a problem, but expect to have a fluctuating idle when you first get the engine running. Bleed the cooling system for about 20min by leaving the cap off the radiator to let the air bubbles escape, then go drive the vehicle around for about 30min, the ecu will do its fuzzy logic routine and adjust the idle. The key in getting rid of the fluctuating idle (if you dont have any vaccum leaks) is driving around for more than 20min so the ECU can learn the motor.

I speak from my experience with a KPRO, not sure if the fluctuating issues occur with a JDM K20 ecu.
Thats good to know.
2fastxeg said:
i think most people run into the problem of aligning their mounts into the chassis bracket... just be patient, if somethign doesnt work out, dont quit, haha you got ot move the motor around a bit till it fits in perfectly.
So would painting the brackets for the mounts not be a good idea as you would need to adjust them when putting in the motor?
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top