Honda / Acura K20a K24a Engine Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
98 Posts
Discussion Starter · #1 ·
i have a 93 si with a k20z1 swap

car runs good but is not really tuned yet

my ecu is throwing a error code

for the o2.

im running an aem wideband and it is not running threw the k pro just to the gauge so i can keep an eye on it.

i have ppl telling me that it will make a huge differance if is ditch the aem and get a denso and run it the way its supposed to be thru the ecu so i can use its readings..

is this true or do other run aftermarket wide bands.


Jesse:confused:
 

·
Registered
Joined
·
2,735 Posts
the aem is just for monitoring, the ecu wont correct or do any adjustments from its reading. having a proper working o2 is great in many ways.
 

·
Registered
Joined
·
1,175 Posts
the white wire comming from the 4 wire plug on the back of the gauge. run a wire from that to the ELD pin of the ecu. than open kmanager , click on OPTIONS , SETTINGS , WIDEBAND INPUT. theres 2 dots , use existing , use external. click the external dot. in the pulldown menu for which wideband , you wont find AEM , but use the PLX setting , its the same. start the car and datalog , than in the voltage offset box , enter whatever value you have to to make Kpro's A/F readout , the exact same as the AEM gauge. the value will be - value. start with -1. now you can datalog your A/F with Kpro.
 

·
Registered
Joined
·
1,175 Posts
Kpro will not use this setup for closed loop. this is for display and tuning only. the ELD pin on the 02-04 is E15. i dont know about the 05-06. im sure someone here has a pinout.
 

·
Registered
Joined
·
98 Posts
Discussion Starter · #8 ·
so i need to get a denso wideband and run it to my ecu so the car can have an o2 to read to help it run better right..

ppl hve told me that i will see a big difference and it will keep that damn error code from coming on every 20 mins

Jesse
 

·
Registered
Joined
·
374 Posts
yeah i would stick to an oem unit.

iirc if you're using an aftermarket wideband the lambda overlay may not work. but it shouldn't matter unless you plan on using it.
 

·
Registered
Joined
·
327 Posts
question related to 02.... on my DTR header there is one 02 bung but it would only read a pair of cylinders. how would that be benificial?>> And once you are fully tuned, there isnt a need for you to run closed loop... right???? just throwing questions out there..
 

·
Registered
Joined
·
457 Posts
mannyman beat me to it. I would recommend putting the AEM in the secondary bung, and if not already disabled, disable secondary in Kpro, and run denso for primary, that way you can run closed loop, and have a instant readout to monitor AF when laptop not in use for datalogging.
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top