Honda / Acura K20a K24a Engine Forum banner
1 - 20 of 24 Posts

·
Registered
Joined
·
484 Posts
Re: q45 throttle body tps wireing

What colors are on your q45 tb?
 

·
Registered
Joined
·
44,673 Posts
Re: q45 throttle body tps wireing

According to that link, on the Q45 throttle body:

Red is the 5 volt input wire

White is the TPS signal wire

Black is the sensor return wire


On all 5VDC TPS sensors I have seen, the two outside wires are 5VDC and ground. The center is the signal. This is the same on Honda. Just wire it up, if it reads wrong in K-pro, swap the outside wires :up:


Edit, found a pic of one installed on a manifold.
http://k20a.org/forum/showthread.php?t=89614&highlight=90mm



Edit v.2, more info and pics in the below thread.
http://k20a.org/forum/showthread.php?t=69927&highlight=90mm


Meanwhile, in my build thread

a very critical and essential part came in today... and its a Nissan part lol

Q45 90mm Throttle Body... $79.99 (yes im proud of that)



This is how it would have bolted on, but its not going to happen without an adaptor. The manifold pattern and TB patter dont match...





By a little bit :(



I noticed the front spring wasnt needed, it also didnt let the throttle plate close 100% (probly a lil jammed). Its a valve that pushes it open, there was a coolant line goin into the backside of it. It probably had something to do with the cold idle. So i got rid of it.

Before.



After. Couldnt get rid of the valve so it will stay there, the coolant entry on the backside of the valve will be blocked off though. The small nut & stud you see on the top of the pic next to the mounting hole is what will be used to set the idle.


I dont have anything at home to measure it so i took a pic. I think the the Q45 tb tapers down to about a 83mm and i think the im inlet is 90mm. Which seems about right, looks like about 3.Xmm around the edges

 

·
Registered
Joined
·
44,673 Posts
Re: q45 throttle body tps wireing

question so if we have to use the q45 tb what about the Map Sensor can we use the hondata ones for boosted applications or have to use the stock nissan one?
You can use the factory one and just tap the manifold for the signal source.
 

·
Registered
Joined
·
79 Posts
I have the afi intake manifold with a q45 throttle body installed in my eg6, the problem i have is that the throttle body opens only 75% at full throttle. Fyi, the throttle body opens all the way by hand, im using a rsx throttle cable, and adjusting the throttle cable without any slack by hand while having someone floor the gas peddle. Does anyone have any helpful suggestions? I would greatly appreciate it.
 

·
Premium Member
Joined
·
5,071 Posts
I have the afi intake manifold with a q45 throttle body installed in my eg6, the problem i have is that the throttle body opens only 75% at full throttle. Fyi, the throttle body opens all the way by hand, im using a rsx throttle cable, and adjusting the throttle cable without any slack by hand while having someone floor the gas peddle. Does anyone have any helpful suggestions? I would greatly appreciate it.
I have the same TB on my dc5. I just put the cable on last night, ill check mine tomorrow n let you know
 

·
Registered
Joined
·
79 Posts
I got a helfpful tip that Mointing point for the throttle cable has a lot to do with it. Make sure the cables mount point is long enough to allow full throttle, also you need the right cable... trial and error.

So my question is mounting the throttle cable bracket on the bottom of my afi intake manifold possible? I could not mount the bracket on top because it would not have clearance in eg6 unlike the dc2.
 

·
Registered
Joined
·
95 Posts
I have the afi intake manifold with a q45 throttle body installed in my eg6, the problem i have is that the throttle body opens only 75% at full throttle. Fyi, the throttle body opens all the way by hand, im using a rsx throttle cable, and adjusting the throttle cable without any slack by hand while having someone floor the gas peddle. Does anyone have any helpful suggestions? I would greatly appreciate it.
i dont know if this help but on mine i just set the volt close to stock a possible when it fully close, I know that you can't set it dead on and when it fully open set it 5 volt and you'll be fine. It works for me with no problem. I use Mr2 throttle cable.
The other thing you can do is look under your gas pedle there should be a srew that you can adjust, try that see if it works.
 
1 - 20 of 24 Posts
Top