Honda / Acura K20a K24a Engine Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
I just finished everything to put the DC5 motor into my integra... everything is hooked up.... all the electric parts work... but the ignition doesnt start and the engine doesnt turn over.... i dont understand why... help.........
 

·
Registered
Joined
·
15 Posts
Discussion Starter #4
I think me and my buddies found out why the car is not starting... lets cross finger and hope the best will happen... details will come after! ^__^
 

·
Registered
Joined
·
929 Posts
make sure plenty of grounds to the motor and fuel pump is wired up.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #6
There is another new problem now... the engine cranks but there is no fuel going through the fuel system... I have already grounded the fuel pump... I am using the Paxton fuel pressure regulator..
 

·
Registered
Joined
·
929 Posts
I know this sounds redundant but..
Can you hear the fuel pump kick on????
What harness are you using??????
may have to hard wire the fuel pump. OR at least test it to see if it is good.

Make sure your power harness is correct(starter and alt wires go to the correct place in the fuse block under the hood).
 

·
Registered
Joined
·
129 Posts
Hey, I've been working on the car too. Can't hear the fuel pump going on, and the FPR reads 0 pressure. Using the hybrid racing harness. Tried switching the wires that go to the fuse box and still nothing.
So probably have to hard wire the fuel pump? Is there a wiring diagram or anything that can help? Thanks.
 

·
Registered
Joined
·
929 Posts
I simply ran the fuel pump power wire from the pump to the fuse block.

There are spades open that get power when the key is on.

If you want you can also run an inline fuse.... I chose not to.

I also ran kill switch for fuel pump....
 

·
Registered
Joined
·
2 Posts
holy shit

God Damn that is soooo nice. Thats exactly what i want to build up an integra like, well except black but still thats just crazy. Enjoy that man!
 

·
Registered
Joined
·
388 Posts
Sounds interesting. I will need some help shortly.

My brother have just swapped out his ITR motor into a 95 teg shell... And now having an empty ITR shell, waiting for a k20aR motor. Any idea who has one locally in USA? Sounds like the Hybrid Harness and Mounts are doing good. How is the AC/PS clearance?

I will consider Hybrids Mounts/Harness if thing looks well. Got a deal for me Hybrid? Considering I may be interested in your kit over the HasSport. :twisted:

Also, How would you be able to run the k20aR ECU...? Would the ignition also be required? Thanks!
 
1 - 20 of 20 Posts
Top