Honda / Acura K20a K24a Engine Forum banner

1 - 20 of 104 Posts

·
Registered
Joined
·
6,415 Posts
Discussion Starter #1 (Edited)
OK guys, I see alot of questions and problems with Primary O2 wiring.
This thread will show you the correct info to check your conversion harness if you are having problems. This should help out several members. This little pic is the wire side of the primary O2 sensor plug. Clip is above the 1 & 2 positions. Pins & plug facing away. Wires coming out towards you.



1 2

3 4

The 4 wires on the Primary O2 need to go to:

1 - Primary O2 Signal (+) (white / red on my harness)
Continuity to C101 pin 19, from there the wire goes back over to ecu A6 where it delivers signal info to the ecu.

2 - Primary O2 Ground (-) (green / blue on my harness)
Continuity to C101 pin 13, from there the wire goes over to ecu A16 which is a sensor ground.

3 - Primary O2 Heater Signal (+) (yellow / black on my harness)
Continuity to C101 pin 15 (from there the wire goes over to ecu A22)
*NOTE: This wire is also divided and is tied into a relay. I will add the relay information a little later.

4 - Primary O2 Heater Ground (-) (orange / blue on my harness)
Continuity to C101 pin 10 (from there the wire goes over to ecu pin A1)
However In some swap harnesses I have seen this wire pinned directly to K-series ecu pin E4. That also works as an appropriate heater ground.

*NOTE: 1 & 2 MUST be wired to the above correct locations for KPro to properly read and display the A/F readings.
*NOTE: 3 & 4 Can be reversed. The heater will still operate without any problem.
 

·
Premium Member
Joined
·
1,509 Posts
Good post Mike, for those having difficulty searching and finding answers. :up:
 

·
Registered
Joined
·
238 Posts
You are awesome. I really needed this a while ago, and searched for days without finding this info. Ended up finding it hidden in the FSM but this would have been invaluable to figure out which wire was which.

Props to you.

Adam
 

·
Registered
Joined
·
697 Posts
Good info. I had this problem when I started up and my conversion harness was pinned wrong, lucky for me hyrbid was open so I called and talked to david, and he gave me the same instructions to check.

Also some more good info, for those curious about what o2 sensor to buy. This another option. I am running a primary o2 from a 03 civic hx civic.
I work at honda so it was cheaper to buy this sensor. But here is a link to show you the other vehicles that use the same sensor, most likely just different wire lengths.

http://www.amazon.com/gp/product/compatibility-chart/B000C5UFVM/ref=au_pf_dp_chart/192-0021812-7340249
 

·
Registered
Joined
·
25 Posts
ok so i have a crx with a rywire harness and the black wire with white stripe is just hanging there and its a ground. when i start the car the relay clicks but i get a code for primary o2 sensor and im guessin this wire goes somewher to the ecu but im not sure please help me guys i need to know where is this wire suppose to go.

 

·
Premium Member
Joined
·
1,509 Posts
Here are some old notes from when I did my own conversion harness in my car.. I hope they are of help to you.

PIN 85 to Female 20 pin plug (PIN 02) and Secondary O2 sensor power
PIN 86 to E plug (PIN 08) GROUND FROM ECU
PIN 87 to Female 20 pin plug (PIN 16) ECU SEEKS O2 Reference Voltage
PIN 87A BLANK
PIN 30 to Female 20 pin plug (PIN 17)
Andre
 

·
Registered
Joined
·
25 Posts
okay so my loose whire is pin 30 which u sed it goes in the 20 pin plug (PIN 17) POWER FOR SENSORS ECT AT IGN. 12V..but im gettin GROUND out of pin 30. and is suppose to be POWER
 

·
Registered
Joined
·
811 Posts
good ish..
 

·
Registered
Joined
·
12,507 Posts
im throwing a cel for the Heated primary catalyst and on kpro at the bottom it says (heated catalyst not supported) like its disabled or something, but its not, shouldnt it say supported, but incomplete? ( if it was a bad sensor? ) also been reading about my swap harness being pinned wrong and turns out it was, and also read once a memeber got rid of his swap harness and changed brands his issue went away. trying to borrow another known working new sensor from someone to completely verify if its a sensor or another issue
 

·
Registered
Joined
·
6,415 Posts
Discussion Starter #20
Ryan,

Check your wiring with my diagram. It is 100% accurate.
Also testing with a known working sensor is a very good idea.

PM me if you need any help buddy. :up:
 
1 - 20 of 104 Posts
Top