Honda / Acura K20a K24a Engine Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
hey guys i have a k20 swap but didn't put it in my car yet. i was trying to put a prc ecu in my car and see what would happen and it started and shut off. what up with it. any ideas.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #3
ehhhhh i have a k20a3 not a b18 if you read i have a 02 si you know a ep3 si hatch. anyway any body else with some comments.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #6
why wn't it work because of the cams. i man differnet style head. i hate the k20a3. my k20a looks so sweet i can't wait to have it in my car. so much for trying out the prc ecu. oh by the way is a prc a ctr or itr ecu.
 

·
Registered
Joined
·
14,750 Posts
whitecivicsi02 said:
why wn't it work because of the cams. i man differnet style head. i hate the k20a3. my k20a looks so sweet i can't wait to have it in my car. so much for trying out the prc ecu. oh by the way is a prc a ctr or itr ecu.
it won't work because of the different vtec settings. PRC is off an honda integra.
 

·
Registered
Joined
·
18 Posts
It won't start because of the security settings in your key and ignition. It would not run well because of the previously mentioned shiz. You need to bypass yer key and ignition sttings as the ecu does not have the info the ignition is looking for.
To the other guys that posted, telling him that it wont work cause it's different is like saying you shouldn't try stuffing a k20a into an eg.....Oh shit that's what this site is for....experimentation.
If the ignition was not asking the ecu for security info then the car would prolly run fine, it would be weak as hell but fine below 5000 rpm
 

·
Registered
Joined
·
24 Posts
Discussion Starter #9
so if i put the k20a swap inmy ep3 02 si it won't work anyway right i hve to change the harness. i know sme guys in ephatch that did the swap and kept the stock harness. need info.
 

·
Registered
Joined
·
45 Posts
SIRMcD said:
It won't start because of the security settings in your key and ignition. It would not run well because of the previously mentioned shiz. You need to bypass yer key and ignition sttings as the ecu does not have the info the ignition is looking for.
To the other guys that posted, telling him that it wont work cause it's different is like saying you shouldn't try stuffing a k20a into an eg.....Oh shit that's what this site is for....experimentation.
If the ignition was not asking the ecu for security info then the car would prolly run fine, it would be weak as hell but fine below 5000 rpm
I thought the Prc didn't have an immoblizer
 

·
Registered
Joined
·
59 Posts
whitecivicsi02 said:
so if i put the k20a swap inmy ep3 02 si it won't work anyway right i hve to change the harness. i know sme guys in ephatch that did the swap and kept the stock harness. need info.
Interesting .....that ecu should start the car ....it wont run good but it should work.

Where are abouts are you located ?

Eric
 

·
Registered
Joined
·
18 Posts
I think it's because the Si has the immobilizer equipment in the ignition switch and key. Even though the ecu does not have this, the key and ignition are still looking for it. Eric, if you find more info on this could you post some info on it.
I know there is a way to disable the immob in the ignition, maybe RSX fans would know.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #13
i'm in ny if you can find more info that will be great about the immobiler.
 
1 - 13 of 13 Posts
Top