Honda / Acura K20a K24a Engine Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Just wondering if this is my CAI or something else, for some reason when I pop my car into neutral when I'm slowing down to come to a stop or going downhill my car revs to 2k and then drops to 1k then goes up again and drops again. It does this until I come to a stop and does slow down the slower I go, and when stop it idle's at a little under 1k.
 

·
/) ^3^(\ <- SO AWESOME!!
Joined
·
2,648 Posts
It might be your IACV (idle air control valve). They're known to stick. I just unscrewed mine from my throttle body, pulled the gasket off and cleaned it with brake cleaner. Reassembled everything, put the gasket back on and screwed it back onto the throttlebody.

Option 2 is to get one of those IACV block-off plates.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #3 ·
I'll have to check that out, just seems to me that there is air getting into the engine causing it to rev higher then drop, only seems to do it if the air is cool once it warms up(outside temperature) it's not as bad.
 

·
Registered
Joined
·
336 Posts
Did you ever Fixed the problem?

cause i have the same problem, when the car sits it idle fine. But when im slowing down and putting the car in neutral it starts to rev up and down very slowly (1000-1800). when i come to a complete stop the idle goes back to normal (under 1k).

i have cleaned the IACV before... What else should i check? or should i re-clean the IACV
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top