Honda / Acura K20a K24a Engine Forum banner
1 - 19 of 19 Posts

·
Registered
Joined
·
562 Posts
Discussion Starter · #1 ·
just installed a DC Sports race header, guy i got it from gave me a good primary but said the secondary was bad, which has a defouler on it. He told me that if i reset the ecu that it wouldnt reconize that bad sensor til about 150 miles which i wont even come close to racing. Is that true or false? i reset the ecu from the fuse box and cleared all the codes from my obdII scanner but keeps throwing a code (o2 sensor circuit no activity detected bank 2 sensor 3) Now would that be the secondary? I unplugged the primary to see if any changes in the scan it and it threw a different o2 sensor code so i plugged it back in, cleared everything and that same code keeps coming up. Will running the secondary like that make much of a different in performance for what im using the car for, dirt oval track??
Thanx
 

·
Registered
Joined
·
2,735 Posts
wut race are you racing in? scca? if so kpro isnt allowed in stock prepared classes. wait wut car is this? if its the delsol in your sig and if you have a swap you cant run in "inexpensive class."

if drag race then iuno.

just get an o2 sim. buying a secondary o2 is expensive and you might as well use that money to save up and get kpro.
 

·
Registered
Joined
·
2,735 Posts

·
Registered
Joined
·
2,735 Posts
dude, we dont even know wut motor you have or any info besides, dc sports header, good primary, bad secondary, defouler and cel.
 

·
Registered
Joined
·
562 Posts
Discussion Starter · #14 ·
dude, we dont even know wut motor you have or any info besides, dc sports header, good primary, bad secondary, defouler and cel.

thats cus this got moved from my original thread, "02 civic si project dirt track car" so its the a3. sorry
 

·
Registered
Joined
·
2,531 Posts
The typeS secondary o2 sensor will work. That is what I have in my EP3.
 

·
Registered
Joined
·
562 Posts
Discussion Starter · #19 ·
Ok finally got a secondary o2 sensor but think the primary sensors ive been trying the whole time are bad since my scanner has been throwing a code p0166 which someone told me is the a/f ratio primary sensor. So now im in a rush to get a primary from a k20a3 if anyone has one let me know. Thanx
 
1 - 19 of 19 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top