Honda / Acura K20a K24a Engine Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
207 Posts
Discussion Starter · #1 ·
Hi, I took the time to register since I've heard that some of the greater k series minds are on this board....

Anyway, I completed my tsx k24a2 swap in my EP about 2 weeks ago. Almost everything runs fine, with the exception of the coolant system. I datalog'd on k-pro today on the way to school and noticed my ECT's averaging at about 215, which is ridiculous. When I would come to a stop, they would gradually climb until my car threw a CEL when they reached 220+ degrees, and if I was stopped long enough they would hit 230ish. It seems like the fans aren't even coming on and its getting cooled by the wind from moving, which is odd because I was having an issue with the fans last week.

Last week, the same sort of thing would happen, except I could just wait for the fans to come on and then they would do their job until I turned the car off, in which case I would have to repeat this process until they came on eventually.

This is the last problems I'm having with my swap, and it's infuriating the hell out of me :mad: I can' figure out what it could be....I've bled the coolant system long enough, and on top of that I have a fat ass koyo aluminum radiator w/ mainly water and some water-wetter (live in texas)

My only solution that I can think of is getting an adjustable fan switch and setting them to come on at a much earlier nicer temperature, but I'd really like to destroy the problem once and for all.

Any ideas? I can email some datalogs out since they're too big to attach...
 

·
Registered
Joined
·
1,216 Posts
My Homie!!!

Good to see you one here bro. Yeah, some of the greater k-series guys are on here.

Bump so someone whos experienced will help alex out.
 

·
Registered
Joined
·
254 Posts
plug the wires from the fan to the battery and see if it works it not you didn't wire up your fan switch correctly , to check if you wired the switch right, just jump the two wires together and it should turn on , if not test a good known switch. or you wired the switch wrong.
 

·
Premium Member
Joined
·
7,171 Posts
You could always just wire them up so they are on the whole time the car is running...
 

·
Premium Member
Joined
·
7,171 Posts
nikos said:
If you had a complete type s head, would it bolt on a tsx complete shortblock with no problems? Anything to consider?
Is this a question Nikos?

If so I think the answere is no. If I remember correctly none of the other heads would bolt right on to the TSX block with no modification. but this is just going off memory, something I remember reading a little while ago...

But I know Edo said that when they first tested there IPS cams that the TSX head showed just as good if not better gains than the ITR head, with the same cams...
 

·
Registered
Joined
·
1,216 Posts
jon v said:
Is this a question Nikos?

If so I think the answere is no. If I remember correctly none of the other heads would bolt right on to the TSX block with no modification. but this is just going off memory, something I remember reading a little while ago...

But I know Edo said that when they first tested there IPS cams that the TSX head showed just as good if not better gains than the ITR head, with the same cams...
YEP, the tsx head apperantly has slightly better flow than the ITR head. The addition of aggressive cams to the TSX is IMO, would make it the best K motor out there(without spending ludicrous amounts of money).
 

·
Registered
Joined
·
207 Posts
Discussion Starter · #8 ·
Actually, all of yesterday I didn't get a single CEL, it was amazing. I don't understand it, so I took the laptop out and did some dataloggin' and found out that when I slowly drive and get on the freeway, the ECT's climbed up to that threashhold right before it would throw a CEL (219.7 deg) and then just gradually dropped back down to the 203-212 area. I know that's still rather high however....

jon v said:
You could always just wire them up so they are on the whole time the car is running...
How can I do this? I don't have the fan switch as of yet, but if I could do this without it then that would be lovely for my ECTs...and overall engine longevity.

Nikos - would be a waste of time and labor IMO b/c they're both very great flowing heads w/ that aggressive thrid lobe. It would make life a little easier if you're the head swapping king, but I think the only advantage to this would be that you wouldn't have to modify the intake manifold or head for the coolant port, but you would have to slightly modify it for it to fit b/c they are 2 different castings, just as you would have to lightly modify a, for example, set of IPS K2 cams to fit in the tsx. /droooollllll ips camm'd cai/rh/exhaust fully tuned k24a2....if I had to venture to guess, that would be in the 250whp area and 200wtq? That's ridiculous.....
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Looks like we ran into some issues. Please come back and try again later
Top