Honda / Acura K20a K24a Engine Forum banner

1 - 20 of 40 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
I just resently bought a k24a2 swap 01 DC 4 (almost 2 months ago) runs on kpro (05-06 prb) has k20a2 trans rbc intake manifold rdx injectors I'm not sure what wiring harness I have obviously when I first bought the car I ran fine @ 225 hp and 173 ft tq after about a day of driving it work and back the car started to jerk and fall on it face like it's not getting fuel got the car home checked the fpr and it wasn't reading got a new k-tuned fpr and gauge start the car it runs and idles fine just like normal and I have 50 psi on the gauge but the car still does the same thing when I give it throttle it jerks and hesitates I check the fpr gauge and it stays the same while I'm giving it throttle from the throttle body I need any help I can get had the car for a while and can't drive it due to this issue it's killing me
 

Attachments

·
Registered
Joined
·
702 Posts
did you datalogg the problem with your kpro?

05-06 does not have kpro in those ecu,you need to do a conversion for a 02-04 ecu(prb etc)
 

·
Registered
Joined
·
32 Posts
Discussion Starter #4
When I bought the car it ran well on this Ecu and the pervious owner said it was also dyno on this Ecu as well little back info of what I know I'm kinda down the rabbit hole right now fml
 

·
Registered
Joined
·
32 Posts
Discussion Starter #6
yes!! Jerks at partial throttle just like what you say and when I try to free rev her she dies out as I'm pressing the throttle can I make a video and post it on here
 

·
Registered
Joined
·
32 Posts
Discussion Starter #8
Ok update to what I said went outside just now fired up the car waited for a min did a couple revs and it did it's thing reved like a champ and my air fuel ratio gauge read 14.7 so I don't know if it starts jerking and stumbling on it self when it's fully warmed up and driving at partial throttle because it did not rev like normal last time I tried to rev it
 

·
Registered
Joined
·
2,523 Posts
Any CEL codes?

If it falls on its face jerking....what's the speed you are going when it finally dies? Is it jerking at low speed and then jerks until it dies? I guess I'd like more detail about the whole scenario. Hard to understand the situation with limited info.

Can you get a tuner to look at the tune on your kpro? Juse guessing but I think you need to modify the tune. But that's cash. You could save rhe current tune onto a flash drive or whatever and try a tune available through Hondata (that'll work with your K24A2). Then see if there is still an issue.

If you got no CEL codes, no electrical connection problems, no coolant issues, plenty of solid grounds (3+), good ECU, and a good tune....should be no issue.
 

·
Registered
Joined
·
2,807 Posts
I had something similar happen and it was caused by a failed TAP (or "TPS") sensor. In my case it idled and ran fine as long as I kept the throttle below ~25%, but above that it would fall on its face. Display throttle position with just ignition on, then slowly push the pedal to the floor; it should smoothly increment from 0 to 100% with no irregular jumps or flat spots.

Another thing to try is while it's idling: go around the engine compartment wiggling any wires you can reach. If you touch an intermittent wire, it'll cause the engine to hiccup. Fix and repeat.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #11
what's the speed you are going when it finally dies? - when I'm going low speed like at take off it jerks right away cuts out for a second then goes back to j
erking been afraid to just mash the throttlee when it does this
Can you get a tuner to look at the tune on your kpro? - no I can't I
live far away from any tuner and I'm the only person I know with a k-swap
When I get the cable for my k-pro I'll see about downloading a new tune
I have no CEL, no electrical problem, no coolant issues, good grounds, as far as I know the Ecu is good and the previous owner said it has been tuned I have a graph I'll post it I don't know weather or not is a good one
 

·
Registered
Joined
·
32 Posts
Discussion Starter #12
Kb58 I'll try both suggestions you gave me and I'll post an update either tonight or tomorrow I thank everyone for their time and help
 

·
Registered
Joined
·
2,807 Posts
It could be an intermittent connection that opens under G force (like acceleration) or resonates at some engine speed, vibrates more, and opens. My suggestion to leave it idling and go around pulling and twisting all the wires you can get at should find it - if it's that.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #16
Hey first I wanna say I really appreciate the help just got off work I'm gonna try both suggestions I'll let her warm up and start grabbing and wiggling wires everywhere I can then I'll go ride the clutch a little see if I get a different reaction
 

·
Registered
Joined
·
32 Posts
Discussion Starter #19
Friday night bout to got mess with the car got the cable ordered for my k-pro hope I don't have to order a new one how do I diagnose if my TPS bad? Thanks for the help
 
1 - 20 of 40 Posts
Top