Honda / Acura K20a K24a Engine Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I was trying to avoid posting but I am lost. I have a 2003 Acura rsx type s.
engine
K24a1 block and crank
04 tsx rods
04 tsx piston
Type s oil pump
Rebuilt K20A2 head
This is my first k series build and I’m lost with the vtec. Things I’ve checked
Of course I put new oil in it and it’s full.
No check engine lights
Vss to ecu
Rpm to ecu
Oil pressure
All gaskets were replaced
Vtec spool
Block vtec pressure switch’s
The one on the solenoid and also the one on the block right below the vtec solenoid
Throttle position sensor.
the hondata so everything operating as it should. the spool coming on,the pressure switch coming on, rpm, speed, throttle and engine temps. I am completely lost I’ve been googling for 2 weeks now and I’ve check everything. Any help is appreciated
 

·
Registered
Joined
·
343 Posts
How are you verifying the vtec isn't working?

The reason i ask is another guy in here had the same issue and tested everything and ended up having a blocked exhaust which was choking power and
Muffling the vtec change over noise.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
How are you verifying the vtec isn't working?

The reason i ask is another guy in here had the same issue and tested everything and ended up having a blocked exhaust which was choking power and
Muffling the vtec change over noise.
Full k tuned exhaust not sure on the header. But normally you can feel a decent power difference when vtec cracks? Especially when you’ve never drove something with vtec. Also when I got the car they had vtec disabled and a shitty tune. So drove it maybe 100 mile the pulled it to rebuild it. Also even on bone stock a rsx types you can hear vtec crack pretty hard
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
Full k tuned exhaust not sure on the header. But normally you can feel a decent power difference when vtec cracks? Especially when you’ve never drove something with vtec. Also when I got the car they had vtec disabled and a shitty tune. So drove it maybe 100 mile the pulled it to rebuild it. Also even on bone stock rsx type s you can hear them crack hard.
 

·
Registered
Joined
·
343 Posts
Full k tuned exhaust not sure on the header. But normally you can feel a decent power difference when vtec cracks? Especially when you’ve never drove something with vtec. Also when I got the car they had vtec disabled and a shitty tune. So drove it maybe 100 mile the pulled it to rebuild it. Also even on bone stock a rsx types you can hear vtec crack pretty hard
The vtc makes the vtec change over much less obvious. Not like B series.

The pressure switch on the vtec solenoid will only switch when the solenoid is working. If your logs show the vtec pressure switch working then it's likely all working as intended.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
The vtc makes the vtec change over much less obvious. Not like B series.

The pressure switch on the vtec solenoid will only switch when the solenoid is working. If your logs show the vtec pressure switch working then it's likely all working as intended.
I appreciate your help. Really thought I’d hear it crack hard when I did this build. I know it doesn’t need to but still sounds cool/good.
 

·
Registered
96 civic HX K24a
Joined
·
2,140 Posts
I was trying to avoid posting but I am lost. I have a 2003 Acura rsx type s.
engine
K24a1 block and crank
04 tsx rods
04 tsx piston
Type s oil pump
Rebuilt K20A2 head
This is my first k series build and I’m lost with the vtec. Things I’ve checked
Of course I put new oil in it and it’s full.
No check engine lights
Vss to ecu
Rpm to ecu
Oil pressure
All gaskets were replaced
Vtec spool
Block vtec pressure switch’s
The one on the solenoid and also the one on the block right below the vtec solenoid
Throttle position sensor.
the hondata so everything operating as it should. the spool coming on,the pressure switch coming on, rpm, speed, throttle and engine temps. I am completely lost I’ve been googling for 2 weeks now and I’ve check everything. Any help is appreciated
Which kpro do you have ? On my v4 display it has a readout that says vtec -on/off. Can you find that on yours and Do a pull to see if it works ?
Font Communication Device Screenshot Technology Software
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #9 ·
Have you try cleaning or possible replacing the VTEC solenoid?
Yes!! Everything was cleaned when the motor was rebuilt. If I was bad I replaced it.
Which kpro do you have ? On my v4 display it has a readout that says vtec -on/off. Can you find that on yours and Do a pull to see if it works ?
View attachment 106665
Mine doesn’t have the vtec on and off like yours just the vtec pressure and vtec spool.
Rectangle Font Wood Tints and shades Pattern

Rectangle Font Mesh Tints and shades Wood

I also did learn just because these are switching from off to on doesn’t mean anything. This is only what the ecu is telling it todo. So it could need just a new assembly but not to sure. I don’t wanna just throw money at it. Thinking about just doing locked vtec.
 

·
Registered
Joined
·
343 Posts
I believe the Vts is the command to activate vtec. Vtp is the response in oil pressure when the solenoid spool opens the oil gallery to the vtec pins.

I have a strong suspicion that if the vtp is changing then your vtec will be engaging.
 
1 - 10 of 10 Posts
Top