Honda / Acura K20a K24a Engine Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter #1
Alright I decided to put the rbc on my k20 swapped si, and the only problem I have ran into is when installing the throttle body the holes wont line up because the IACV is pushing into the radiator....I have the ekk1 mounts. let me know any suggestions
 

·
Registered
Joined
·
104 Posts
i ran into the same problem. i have an ekk20 with the ekk1 mounts also. when i installed my rbc, my iacv was interfering with my radiator and my fan. with the fan, i flipped it and now it blows air through my radiator. but that still didnt fix the problem. with the iacv, my friend gave me a modified harness (which is hard to explain), but i will try to take a picture of my setup and post it up in which it will give you a better/much clearer picture.

my friend purchased the harness from here, so if anyone knows of what i'm talking about, please feel free to chime in.
 

·
Registered
Joined
·
64 Posts
Discussion Starter #3
i ran into the same problem. i have an ekk20 with the ekk1 mounts also. when i installed my rbc, my iacv was interfering with my radiator and my fan. with the fan, i flipped it and now it blows air through my radiator. but that still didnt fix the problem. with the iacv, my friend gave me a modified harness (which is hard to explain), but i will try to take a picture of my setup and post it up in which it will give you a better/much clearer picture.

my friend purchased the harness from here, so if anyone knows of what i'm talking about, please feel free to chime in.
So you still have the stock radiator?
 

·
Registered
Joined
·
104 Posts
yes i still have the stock radiator. sorry man, but i haven't taken a pic of the rbc setup yet. just been busy with school and work. trying to install a roll bar, but thats taking me a while because and once again school and work.
 
1 - 4 of 4 Posts
Top