Honda / Acura K20a K24a Engine Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
404 Posts
Discussion Starter #1
ok so ive started my build in the last week and i got my the old b18c1 out and ive been prepping the bay for the K.....so as i was doing this i ended up with some questions

1) did you have to remove your ABS system(not hardlines just the box thing by the passenger fender) in order to install your passenger side mount and then reinstall it? ( i have the gen 2 hybrid racing mounts )

2) what did yall do to loop your power steering, i removed the hardline and was just wondering, did yall just leave the hardline and cut about an inch or two before the fitting and strap a hose around it, or did you get a fitting to replace it similar to the one above the hardline that the hose connects to that runs to the power steering pump?

3) i cant find my install guide i got with my mounts, anyone know where i can get one? i couldnt find it on hybrid racings page

4) the harness plugs that are at the shock towers where the engine harness is unplugged for removal of the b series......do these connect to anything on the k series, or am i supposed to remove more of the harness? (please answer with detail)

ummm i think thats it for now, just reply with the # of the question and an answer to keep it simple, thanks ahead of time for all the help:up:
 

·
Premium Member
Joined
·
1,017 Posts
1. no i didnt have to remove anything from the abs to istall the mounts. i have 99 so its the smaller of the abs units. not sure about the 94-97 units. theyre kinda huge.
2. i have to find the link. but usually people put the reservoir next to the clutch reservoir then use a y to connect the two lines comin from the rack. correct me if im wrong.
3. pm or call hybrid racing the have it in pdf format. they should email it to you
4.they go no where you can completly remove them out of the engine bay to make it look cleaner. pull them through the grommet and tuck them away inside the cabin.
 

·
Registered
Joined
·
404 Posts
Discussion Starter #3
Ya I have a 94 so the abs is huge.... I'll take those wires and tuck them ASAP.... As far asthe PS goes iwould like tohear more about that and see picsplease
 

·
Premium Member
Joined
·
1,017 Posts
if anything just unplug all the sensors from the abs unit. unclip it from the shock tower, unbolt it from the its giirdle and move it out of the way. my bro has a 94 teg and thats what we did to work around it. then when your done reconnect everything. i had picks of ps loops but cant find it. just search on here p/s loop
 
1 - 4 of 4 Posts
Top