Honda / Acura K20a K24a Engine Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey, I'm new to using forums so be gentle. Lol

So, my problem is this. I have a 02 RSX S race car with built k24/k20 with kpro V4. It ran great. I swapped it into an EG race car and now it doesn't run right. The EG has the very minimum necessities to run.

The car will crank and run pretty good at low rpms, but once I rev it up it starts busting up around 5000 rpm. It doesn't do it every time though. Sometimes it will rev to 7200. The rev limit is set at 8500.

I know the multiplexer must be disabled in kpro being the EG doesn't have it. The RSX S didn't have an A/F gauge but the EG has AEM A/F gauge. I tried using the external wideband and in and even tried running Disabled (open loop and still does the same thing.

With the issues that are happening, I honestly feel like it's possibly in the software or something. I'm using the newest version of k pro software which I believe is 4.4.6 on brand new laptop I just bought yesterday specifically for this. I checked for updates and it's all up to date. I check usb driver test and it says not compatible. I tried to update drivers and it gives me and error but no number or anything to specify what the error is.

Sorry for the long thread, but if anyone has any suggestions, I'm open to try whatever you may think it is.

I thought if the laptop can connect to the ECU then the drivers were fine. Which that may not be correct.

I tried the ECU on different car with the correct tune for it and it seems to work fine. The RSX S was tuned and made 256 hp.
 
1 - 2 of 2 Posts
Top