Honda / Acura K20a K24a Engine Forum banner

1601 - 1620 of 1628 Posts

·
Registered
Joined
·
2 Posts
Yep a thread for me lol. My name is Jason I live in Ontario Canada and just bought my first Acura. I've wanted this car for years but was waiting for the right one to come my way. I just bought 2004 rsx premium with 58000 km. The car is extremely clean inside and out. The body has no rust at all, the interior still smells like new car smell but I did buy it unrunning. I am mechanically inclined and a damn good fabricator and plan to go all out. Right now I'm just trying to get it running so I can get it safetied but I need help I've run into a wall. I have checked compression and got 160 across all 4 cylinders, the car is getting spark as it will sputter with quick start. I have checked the fuel pump and can hear it prime and fuel gets up to the rail just not into the engine. I've pulled the plugs and the are dry. I've put new plugs in when I first bought it. The car cranks fine, there is an srs light on the dash but I don't think that would stop it from starting, the driver's door panel is also removed. The one weird thing I have noticed is that the green key immobilizer light doesn't come on at all. I've read that it is supposed to come for a couple seconds and go out but mine doesn't at all. I called acura and they say if it was the immobilizer the fuel pump wouldn't run or the car wouldn't turn over at all. They said nothing would happen, don't know how true this is. I tried reading codes with a borrowed scanner but their were none. The scanner had a system quality check and a green, orange or red light were the options and mine was orange. Checked all the typical stuff like grounds, fuses, relays etc. Any help would be awesome, if I can't get it going Acura dealer is my last resort but I want to do my due diligence and try myself first. Thank you for any and all help in advance
 

·
Arouse the DAMPFHAMMER!
Joined
·
6,377 Posts
Hi to all!:)
Welcome here storm_tr00per! What is your car and engine?

...I have checked compression and got 160 across all 4 cylinders, the car is getting spark as it will sputter with quick start. I have checked the fuel pump and can hear it prime and fuel gets up to the rail just not into the engine. I've pulled the plugs and the are dry. I've put new plugs in when I first bought it. The car cranks fine, there is an srs light on the dash but I don't think that would stop it from starting, the driver's door panel is also removed. The one weird thing I have noticed is that the green key immobilizer light doesn't come on at all...
Welcome here to K20a.org MasterFab, your AKA is promising :)! Sorry for your engine troubles. Normally an RSX Type S has an K20A2 or K20Z1...CSX had also the K20Z3, all share the 11.0:1 compression ratio, giving a compression test level of 190-210 psi normally. Your measured value sounds like it is a K20A3 with 9.8:1 compression ratio. What is now fact?
 

·
Registered
Joined
·
1 Posts
Hello everybody,

My name is Markus, writing from Germany.
Driving a 99 Lotus Elise S1 with a K20a and sadev transmission

Gesendet von meinem EML-L29 mit Tapatalk
 

·
Arouse the DAMPFHAMMER!
Joined
·
6,377 Posts
...Driving a 99 Lotus Elise S1 with a K20a and sadev transmission...
Welcome to K20A.org Markus! Very nice, another Lotus guy...now we are three which are listen to the name Mark..., coming from Germany, driving a Lotus Elise (not only S1 :D), meeting in a US forum to clarify questions to an Japanese genios engine...and we all are driving all motor K20'ies. I am looking forward to read more from your engine/gearbox and what you intend to do with it.

Markus
 

·
Registered
Joined
·
2 Posts
Thank you for the welcome. I have since fixed the issue with my car. It was the immobilizer gone bad. The green key wasn't flashing at all so I went to the local pick and save and got a new immobilizer for $10. The green key came on so I knew it was an immobilizer issue. I then found a k tuned immobilizer bypass on Kijiji. Installed it and it fired right up. Now it's time to start fabricating some parts and building a fun daily driver. The more I look into k pro the more I want to try and create an open source running package for k series. I have the hardware knowledge to do so. I think the k community as a whole could greatly benefit by unlocking these ecus.
 

·
Arouse the DAMPFHAMMER!
Joined
·
6,377 Posts
...I have since fixed the issue with my car. ...I think the k community as a whole could greatly benefit by unlocking these ecus.
These are very good news MasterFab :up:. Which ECU Type do you have, the flashable Z-type or the non-flashable A-type? Do you know Doctronic? May it is worth to look at their website www.doctronic.at, just as an example what the market already offer.
 

·
Registered
Joined
·
3 Posts
Hi, I’m from Westchester NY and I own a 1995 SI EG hatch with a K20A and also a 1992 EG hatch shell in very nice shape. Currently I’m in the marked for a J swapped EK or EG, I’m a serious buyer.
 

·
Registered
Joined
·
6 Posts
Hi I got an 04 Rsx type s, my engine blew a month after I bought it and then I swapped it for a k24a2 from a tsx. Car ran well for 3ish months but then blew again, ppl told me low oil but I wasn’t convinced. I’m doing the swap again with another k24a2 but I’m just confused on one thing. Do I need to get it tuned? Or do I need something I’ve read about called kpro? I’m just confused on what to do after I drop the engine in, what’s next after that???
 

·
Arouse the DAMPFHAMMER!
Joined
·
6,377 Posts
K24a3 mate.
Best engine in Europe with 99 mm stroke :D.

...I’m just confused on what to do after I drop the engine in, what’s next after that???
Welcome JakG :). Can you tell me please how do you run this engines, like which area, how do you shift, how much redline peaks per minute, traction of the track, which oil do you fill in...such stuff?
 

·
Registered
Joined
·
6 Posts
Well it’s my daily, I don’t really abuse the car and I rarely even redline the thing. The engine has rod knock and at the time I had Mobil 1 oil in it. When I’m just driving around I try to shift below 3 because it’s straight piped and it’s stupid loud. I do rev it a few times a day but not til redline. When I em fooling around I never push the car til it’ limit. I gotta admit the oil level wasn’t the higher when it blew. I’m just trying to seek guidance before I commit the same mistake and give up on this car.
 

·
Registered
Joined
·
9 Posts
Hi guys Kaspa here from down under in sunny Queensland Australia, i have a little Lotus 23 race car i built with a K24 Z3 turbo in the rear, fun little jigger, it only weighs 540kg and has a modest 295 RWHP and 450ft lbs of torque on just 10lbs of boost at 7000rpm, Being very new to the Honda engine as ive never worked on one before, so if i ask the occasional dumb question go easy on me.
https://flic.kr/p/2hvKb6q https://flic.kr/p/25bMqyB cheers Kaspa
 

·
Registered
Joined
·
7 Posts
Hello all, new guy here, bought a k20a swapped 97 hatch as my first Honda project. I've been fixing it up and learning along the way. Hopefully I'll get to drive it more than around the block soon. I posted a build thread but it didn't take.
 
1601 - 1620 of 1628 Posts
Top