Honda / Acura K20a K24a Engine Forum banner
1 - 20 of 38 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter · #1 ·
my passangers side mount doesn't line up properaly in my engine by i was wondering if anyone else has had this problem and how do i fix it ... drill another hole...?




thanks help is greatly apreciated
 

·
Premium Member
Joined
·
26,613 Posts
Re: inovative moount trouble!!!!

Isnt the install for a RHD engine bay different from LHD?? :confused:

Bad enough that your situation is more complicated than the norm with the RHD/LHD thing, but you went with the wrong company as well. :eek:... GL..
 

·
Registered
Joined
·
630 Posts
Re: inovative moount trouble!!!!

well first off rhd efs are diffrent unless that one came with a singal cam then its the same as us or that mount kit might be wrong it looks like it could be for da body
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #14 ·
Re: inovative moount trouble!!!!

well first off rhd efs are diffrent unless that one came with a singal cam then its the same as us or that mount kit might be wrong it looks like it could be for da body
this is a sir 2 came with stock b16 and also i have solved the rear mount issue and it's just that dam passangers one lining up :(
 

·
Registered
Joined
·
16 Posts
Re: inovative moount trouble!!!!

Why dont you post up the info to get everyone fixed so people know in the future?

In case someone in the future comes across this same situation, they will know :up:
There is no problem with the kit. He purchased a kit for the US EF and he has a RHD EF. All of the Innovative kits that I have used worked great.
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #19 ·
Re: innovative moount trouble!!!!

what car are those mounts for? are they for a DA or EF? that mount ur having a problem with looks to be the wrong width. i had to use a spacer for my Hasport mount setup...
it's a crx mount kit and ya i made a spacer just like yours but it is off from the bolt hole also your hasport usdm ef mounts worked in your rhd crx no problem besides the rear one so why would inovative my a kit that wouldn't even fit a usdm crx since the mount is in the same location.....and i also belive there is so diffrence in a tsx timing chain mount compaird to a crv one i brought mine into honda and we compaired it on the computer if someone can tell me how there diffrent i will order one and re-test fit it
 

·
Registered
Joined
·
70 Posts
Re: innovative moount trouble!!!!

it's a crx mount kit and ya i made a spacer just like yours but it is off from the bolt hole also your hasport usdm ef mounts worked in your rhd crx no problem besides the rear one so why would inovative my a kit that wouldn't even fit a usdm crx since the mount is in the same location.....and i also belive there is so diffrence in a tsx timing chain mount compaird to a crv one i brought mine into honda and we compaired it on the computer if someone can tell me how there diffrent i will order one and re-test fit it
if the mounts are the correct ones (for usdm crx), then the only thing i can think off is ur driver's mount is in the wrong spot. did u test fit before welding the mount on?
 
1 - 20 of 38 Posts
Top