Honda / Acura K20a K24a Engine Forum banner

1 - 5 of 5 Posts

·
Registered
2005 Acura RSX Type s K20z1
Joined
·
2 Posts
Discussion Starter #1
Hey guys I’m new here. Gotta 05 RSX Type s K20z1!
A while back I was driving in the rain and hit a patch of water, my cold air intake runs down in front of the left front tire. It sucked a little water up and got my spark plugs wet and my engine stalled on the side of the highway. After waiting while I tried to start it, it turned over fine but just wouldn’t start.
After I had it towed to a shop the mechanic just held over the ignition for about 30 seconds until it finally started.
It idled very rough and lots of white smoke was coming from the exhaust. I let it idle for a few minutes and it stopped blowing smoke and the idle returned to normal.
I drove it home but the engine had no power and the check engine light came on.
After a few miles the engine returned to normal and stopped having misfires.
I changed the oil to be safe.
The check engine light is still on and there’s a lot of engine vibrationat at idle.
What should I do to make sure the engine is ok and make the check engine light go away?
Sorry for the long story btw
102680
 

·
Arouse the DAMPFHAMMER!
Joined
·
6,369 Posts
Hey guys I’m new here. Gotta 05 RSX Type s K20z1!
A while back I was driving in the rain and hit a patch of water, my cold air intake runs down in front of the left front tire. It sucked a little water up and got my spark plugs wet and my engine stalled on the side of the highway. After waiting while I tried to start it, it turned over fine but just wouldn’t start.
After I had it towed to a shop the mechanic just held over the ignition for about 30 seconds until it finally started.
It idled very rough and lots of white smoke was coming from the exhaust. I let it idle for a few minutes and it stopped blowing smoke and the idle returned to normal.
I drove it home but the engine had no power and the check engine light came on.
After a few miles the engine returned to normal and stopped having misfires.
I changed the oil to be safe.
The check engine light is still on and there’s a lot of engine vibrationat at idle.
What should I do to make sure the engine is ok and make the check engine light go away?
Sorry for the long story btw View attachment 102680
You need to do a leackage test. Likely that something got damaged if it was a hydrolock. The leakage test will give you a indication what. Remove the venting cab If the coolant to hear if air bubbles come up.
 

·
Registered
Joined
·
463 Posts
^^ leakdown and compression test like Markus said will be able to tell you the most about what’s going on in there.
 

·
Registered
Joined
·
174 Posts
i would assume anything under vacuum sensor wise could have water in them as well. i hope a leakdown and compression test rule out the majors
 

·
Premium Member
Joined
·
213 Posts
I seen Jet ski engines Hydro locked but never a car engine, for water to pass through the air filter and in to cylinders you would need to dip the damn filter in water lol, if that's what happened hopefully the rods did not bend, i would pull the Intake manifold and make sure there is no water still sitting inside of it, if there is drain it and put it back on.
 
1 - 5 of 5 Posts
Top