Honda / Acura K20a K24a Engine Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I am lightbulb from CRSX so i figured i would copy and paste this here as well
i have a 03ep3 5 speed case with 1-4ppg straight cuts 5rsx and 6tsx with 4.7 final drive..... the ep3 and 02-04 rsx uses a different type speed sensor thant the 05-06 rsx. I wasnt necessarily worried about the speedo not working i just wanted the ecu to read speed so I can use 2step and vtec both, so i called my nearest hondata dealer and they told me what i was wanting to do wouldnt work, so then i called HONDATA themselves and the guy told me there was no way to make the ecu read speed or get the speedometer to work i would have to swap transmission cases but to me that just didnt make since why my idea wouldnt work so i gave it a shot and here are the results...Also for this to work you must have KPRO...

FIRST i took the 02-04 vss sensor and used a dremel to remove the two plastic pieces inside the sensor..here is a pic of the two peices

Here is a picture after being dremel away




SECOND take a razor and shave off the two side pieces, after completing step one and two the 05-06 harness connector will fit onto the 02-04 sensor connector..
Here is a picture of plastic side pieces that need to be shaved off there is one on both sides of the sensor

After that the 05-06 connector will plug onto the sensor


THRID the harness +12, ground, and signal wires are different between the 02-04 and 05-06 harness so a rewire of the harness will be necessary, cut,strip and reconnect the wires like i have shown in the picture...


After reconnecting the wires put back in loom and tape up and plug the connector into the sensor


FORTH Open up your kal in kmanager, go to parameters, click on the misc tab, now usually for your speedo to work on an 05-06 rsx you will need to check the box marked countershaft driven speed sensor..But for this to work you will need to uncheck that box...Now you are ready to go and everything should work correctly, if you are running different gears like me instead of the stock gears dont forget to click on the gear comp tab and re enter your new gear ratios...
Here is a video showing that speedo is working and that ecu is now reading speed
http://www.youtube.com/watch?v=iYqebhU8MOw&context=C3d5fb2dADOEgsToPDskL9Fyl5BpEXDpKwz8369axy

I have not tested the accuracy of the speedometer yet the primary goal of this is so vtec and 2step will work, also this is done without the use of a frequency converter
 

·
Registered
Joined
·
36 Posts
Sorry to bump this old ass thread but I was having the same issue and if you don't want to damage your 02-04 type s sensor just go to a local scrap yard and grab a b series or d series speed sensor 3 wire pigtail, it plugs right into the 02-04 sensor and all you have to do is re-wire the way the gentleman up there explained.
 
1 - 5 of 5 Posts
Top