Honda / Acura K20a K24a Engine Forum banner

Honda Civic EP2 K20A2 swap. Idle problem

2294 Views 15 Replies 6 Participants Last post by  nomdatyper
Having a serious issue getting my k swap running. Went over everything looked at so many forums and videos. The issue I'm having is it takes a lot of cranking but eventually starts rpm jumps to 3,000 drops to 500 rpm runs rough then stalls even if I apply any throttle it causes it to stall. I've replaced both lamda sensors NGK pre cat and Bosch post cat (not cheap sensors), both cam position sensors, crank position sensor, spark plugs are fine replaced recently when it was in my Type R (when it was running perfectly fine), Throttle body has a geniune TPS Sensor just replaced, IACV is new, EVAP is new, reapplied the gasket with RTV in case the thermal gasket was an issue, coils are fine checked them all for spark even if that was an issue it would just misfire, knock sensor is new, all the gaskets have been replaced before the engine was swapped in everything torqued to spec. Grounds are new and wire brushed the contacts on the valve cover to strut tower, ground from intake manifold to radiator support, ground from gearbox to chassis, moved the ground for injectors to the side of the head instead of the manifold as it's recommended by Hondata. Timing chain and tensioner is new and timed up right, lightened flywheel and clutch. Recently just bought a K Pro so now I have full control tried to disable to EVAP, IACV, calibrate the TPS (only showing -5 min and 40% max which is weird might be adding to the issue). The calibration I am using is the factory calibrated European EP3 which is where the engine is from, made sure it was running in Narrowband mode. Fuel pump primes, tried switching over the fuel pressure reg inside the tank, the fuel strainer and filter is brand new also. Engine bay harness, engine bay fuse box, dash fuse box and the whole harness was swapped out of the Type R also to make sure non of the wiring can cause any issues. Immobiliser, keyless lock etc all swapped over too even although it doesn't matter now that I have a K Pro. Started this swap on the 16th of August had it done by the 22nd only been able to drive it once about 200 ft before it stalled and wouldn't start again at this point all it had was the K Tuned conversion harness which ended up having issues with reading the lamda hence why I've swapped over the whole dash harness from the Type R.

Injectors were showing 10 ms and flashing red in the data log display in hondata, don't think that's normal maybe it's because of cold start ? I'm not entirely sure but I did change the gaskets for the injectors gave them a blast with brake cleaner to make sure they weren't clogged.

Last resort would be to check the timing which I'm 99% sure it isn't because its a brand new chain, guides and tensioner from Honda. Cams were lined up perfectly with the timing pins in the back to stop them turning, crank timing mark was lined up exact.

If anyone knows what I should try please let me know this problem is getting to me and nobody local will even touch it, qualified mechanic or auto electrician. A tuner was meant to show up one day but didn't show and ignores me, non of my car friends are willing to come out and look at it just suggestions for things I've already tried.
See less See more
1 - 10 of 16 Posts
I kinda had a issue like this before when i swapped my EM2. I checked for vacuum leaks, deleted the idle air assist valve, bought a new idle air control, bought a acuity TPS and my issue was still there. Though, i was able to drive it still, the car would be really jerky, like someone was turning the motor off and on every 2 seconds. My issue was the 02 sensor, i just had to buy a oem rsx wideband for it.

I always hate throwing money at a problem i kinda don't know how to fix when you thought of everything. Cause my idle was jumping up and down, as if i was hunting for idle.

In your case, id try a new tps sensor and calibrating it, mine is -1% off and 103% floored

Also try running it in open loop and disable closed loop to see if that does anything
So far I've replaced the TPS with a genuine one from Tegiwa, calibrated it works 0 - 100% spot on. Now it won't start even looking at datalogs the o2 sensor was at 4.1v not moving anymore and 0mA. I gave it a break before I end up stressed out anymore about it and ordered an AEM wideband 30-0300 sensor and gauge wired it up properly. reading just fine but it won't start. injectors are showing 30ms and in the reg on the datalog. I'm just using the factory calibration file with the wideband all set up in closed loop and it just won't fire up just keeps cranking.
welcome to and thank you for registering.
Thank you :)
Hey, I might be worth starting a fresh, check your basics, spark, fuel and timing. One you have 100% confirmed them move outwards.
Remove the spark plugs, if they are wet you can confirm you have fuel, and that your probably won’t have spark, if they are dry, we’ll you have no fuel.
while your there with the spark plugs out whip the cam cover off and check timing.

after all that’s proven good.
What’s your fuel pressure set to?
Do you have any fault codes? Cam and crank sensors all good? No water in the plugs for them.
Hope this helps 👍🏻
Checked all that it's getting spark, can smell fuel when cranking it's always been getting fuel but I did take out the fuel rail left it all plugged in and let the injectors spray while cranking to see what the spray pattern is like. none of them are clogged or dripping badly. checked the timing but can only check the cams since I've got hasport conversion mounts that take up all the space on the timing cover side of the engine. cams are lining up just fine. I've no idea what the fuel pressure is set to it's all stock it's an EP so the fuel pressure regulator is in the tank. No fault codes. changed the cam and crank pos sensors.

I have Integra with k20a2 basically done everything you posted word for word.
I replaced everything even the 02 sensor. Let me know what you come up with and I'll post back as well.
No two different cars but maybe. I'm try replacing my rsx A/F wideband again as my car sat all year till recently.
Hopefully, that's it if not winter is coming im taken it apart, and starting over next year is a new year.
I have no CEL just for the secondary 02 sensor but it's turned off in kpro and is my doing.
The EP and DC5 Integra and almost identical in terms of chassis, I'm sure the Integra has hydraulic power steering though. Anyway before getting a K Pro and the AEM Wideband, I completely rewired the harness leading to the primary and secondary o2 sensors making sure there getting the right voltage, grounds and the ECU is getting the right signals. It did manage to run well over a month ago that's when I was able to drive probably 100ft before it stalled and wouldn't start again. The EP3 Type R in the UK is narrowband last time I checked before changing to Wideband. It was getting 4.1v constant and 0 mA current don't know why I've rewired it so many times checked it so many times that nothing was shorting out under the dash etc. Switched to Wideband it's reading fine but it's off a bit and I've ground it where Hondata and everyone recommends the chassis or intake manifold the gauge could be showing 13:1 and the ECU is reading 11:1 or vice versa. The sensor is getting 12v switched power from the cig lighter, ground to intake manifold. White analog data to analog 1 and brown to the ground on the last pin inside the ECU. However the Map sensor is showing 0.7 psi cranking and doing nothing but it was working fine before haven't touched it.

I'll post my datalog of it running rough with the narrowband and where I am now only able to crank it with the wideband was expecting it to run this time.
See less See more
Attached the datalog, file 2 is when it was running with the narrowband and file "crank no start" is the last time I've tried to get it running

Sorry, I am too busy at the moment. Maybe I find some time this week to check out your log.
Don't worry about it, I've been busy with work anyway not had a chance to try doing more troubleshooting. Was bumping the post up to see if anyone else on the forum had any ideas.
I've skimmed it. Your TPS is no proper signal. Seems it is dead. The MAP sensor signal makes no sense, it shows in idle speed around 80 kPa (which is WOT area). The ECU does it job and enriches the mixture according the WOT correction tables and corrects that mass of fuel every 0.5 seconds. This overfuels your engine, makes idle running rough and so on. Check your harness and the sensors. Eventually change these two sensors.
Was that the crank no start file. I've changed the TPS with a genuine one. Reads 0 to 100 never touched the throttle when I was cranking it. Map sensor I have no idea why it's no reading right checked the 5v reference it's 4.98v middle pin is around 3v and ground it grounded. This was with ignition on and back probing while the sensor is plugged in, got a spare map sensor and made no difference. I'll trace back the wires for the MAP and TPS sensors make sure there is no short but I've not touched the engine harness at all. Doesn't make sense why it isn't reading anymore. Was working fine before.
1 - 10 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.