Honda / Acura K20a K24a Engine Forum banner
Status
Not open for further replies.
1 - 20 of 35 Posts

·
Registered
Joined
·
68 Posts
Discussion Starter · #1 ·
04 a2 in my 98 ek hatch with the hybrid mounts, type r intake manifold, type r ecu, dc full race header, bored throttle body and adaptor plate, str fuel rail, type r lsd tranny, stage 3 clutch masters clutch.....3 inch spoon sports exhaust no cat or resig. Thats the car.....recently I was driving, breaking in the brran new clutch, and tranny, workin the gears and everything, and Im driving, and I hear this bolt dropping sound.....im like ok I ran somethin over......i pull over pop my hood, and the driver side mount, ripped the 2 bolts out of the metal of the car...the mount didnt break! the 2 bolts and nuts ripped OUT OF THE FRAME!!!! and left me with a CRATER of a hole!!! what do i do!!!!!!!!!!!!!!!!!!!!!
 

·
Premium Member
Joined
·
4,224 Posts
Sounds like you have the old EK all billet mounts. There are actually 3 bolts on the top. Either way give me a call and I can give you some feedback and help you get the car back up an running.
 

·
Registered
Joined
·
21,783 Posts
nice to see hybrid step in and offer help quickly though:up: best of luck gettin back on the road man
 

·
Premium Member
Joined
·
26,613 Posts
04 a2 in my 98 ek hatch with the hybrid mounts, type r intake manifold, type r ecu, dc full race header, bored throttle body and adaptor plate, str fuel rail, type r lsd tranny, stage 3 clutch masters clutch.....3 inch spoon sports exhaust no cat or resig. Thats the car.....recently I was driving, breaking in the brran new clutch, and tranny, workin the gears and everything, and Im driving, and I hear this bolt dropping sound.....im like ok I ran somethin over......i pull over pop my hood, and the driver side mount, ripped the 2 bolts out of the metal of the car...the mount didnt break! the 2 bolts and nuts ripped OUT OF THE FRAME!!!! and left me with a CRATER of a hole!!! what do i do!!!!!!!!!!!!!!!!!!!!!
I don't get it.. Are you claiming a discrepancy with Hybrid or the Bolts??.. Sounds like the mounts have nothing to do with it IMO.. Pics please.
 

·
Registered
Joined
·
294 Posts
that is deffinetly some hybrid assistance there. some of the best out there no doubt about it. and the original all billet mounts that were designed from hybrid were set up a little odd compared to the new v.2 or hasports.

of coarse without having seen any pics, and depending on the size of the hole it should be able to be rewelded, grinded, and re-sprayed to start again.
 

·
Infinite levels to this..
Joined
·
25,372 Posts
recently My timing chain tensioner went all to hell and threw the motor outta timing.....replaced the chain and tensioner bran new.....the car is in time, and idols perfect, jus sits on 1000 all day, np sputs spirts, chokes or coughs. but when you get goin, ther jus isnt ANY power, vtech wants to crack, but doesnt.....i never reset any timing codes, or the crank angle sensor, what If i reset all the codes npw that its back in timing????? will that fix my problem???? cause a k with no vtech is horrible :(!!!!!!
thats what I was thinking first, mayb when it got outta timing when I was driving, it bent a valve and lost compression in one of the cylinders, but ill do a compression check today, and get back on here and see what happens. thanks :)
this has to be a scam. he's apparently been driving the swap long enough for the tensioner to go out, install the new one, drive it again. now all of a sudden out of the blue two mount bolts just rip straight through the mount holes? get the **** outta here. pics or ban :down::down::down:
 
1 - 20 of 35 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Status
Not open for further replies.
Top