Honda / Acura K20a K24a Engine Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
64 Posts
Well got the motor in today, but the stock header and stock sway bar fit just fine. I don't know why people are saying it doesn't work. Mine fit perfect.

The only thing I can think of maybe because it's a base model and not a type-s. Is there a possibility that the type-s utilizes a different sway bar?
Whats up Bro. Im doing the same swap. I have a base 5 speed as well.

Things you need.
CRV Timing Cover Mounts

They say 75a Bushings are recomended, but im gonna use the 60A that i just bought not too long ago.

Do u have Kpro?

What Intake Manifold are u running?

Regardless your gonna need an Aftermaket TB or Type S TB and need to rewire the TPS.

Have to get the Injen CAI if ur gonna run a CAI with the RBC, otherwise u can just make a custom short ram.

I suggest upgrading your injectors as the Base injectors only @ 270cc. I Run full bolt-ons on my A3 and my duty cycle is at 90%.

Im running the DCRH, if i run into clearance issues ill try the EM2, if that fails i run without one.

And u should get at least a 2.5 inch exhaust for the 2.4 Liter Beast

Good Luck:up:
 

· Registered
Joined
·
64 Posts
Well I got the motor in the car with the mount, a lot of people kept saying that the header wouldn't clear at all. I'm getting k-pro done right now, I'm using the stock base (plastic) intake manifold with stock TB. Where did you hear about the tps rewire? After all the searching I didn't see anything about that at all.


Thanks for the reply
Im almost 100% that the Stockbase IM WILL NOT Fit. The k24 has the Watercoolant bypass thats works with the IM made for the K24. Only way around is to get a special gakset that Hasport makes.

A rewire is needed if its a Type S Throttle Body because the Sensors are facing different ways.
 

· Registered
Joined
·
64 Posts
So i did my swap about 2 months ago. Car runs great.

Yeah, the base IM will not fit bro. Are u sure u did the research before approchin this task.

You will only have to rewire the TPS if u are using a Type S TB
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top