Honda / Acura K20a K24a Engine Forum banner

41 - 59 of 59 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #42
Alright got a key, immobilizer and ecu from a parts car. I installed them in mine and the car is now running on 4 cylinders but I still have the p1361 check engine and 3k limiter. I ordered a crank sensor and will see if that fixes it.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #43
I put a new sensor in. Now the car doesn't want to start. I'll crank it for a bit and it will feel like it will start going to 2k rpm and then just dieing.
 

·
Arouse the DAMPFHAMMER!
Joined
·
6,266 Posts
Markings? What do you mean? Was k not supposed to just take the old sensor out and put a new one in? Is there more that needs to be done?
Ah, I see what you mean. Basically you are right, old sensor out, new sensor in. My thought was, if the old and the new doesn't change the result significantly then a check of the markings would be the next step to get the issue analyzed.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #47
Ah, I see what you mean. Basically you are right, old sensor out, new sensor in. My thought was, if the old and the new doesn't change the result significantly then a check of the markings would be the next step to get the issue analyzed.
I honestly don't know what to do at this point, I have a spare harness for the engine might try to replace the old one with but the car at least ran before I swapped the sensor. When I'm cranking the car, it wants to run but I feel like there is a cut off stopping it? ( I'm also taking apart the rear suspension putting new bushings in, I don't think it would be an issue that would stop the car from starting? Not having the rear abs plugged in currently)
 

·
Arouse the DAMPFHAMMER!
Joined
·
6,266 Posts
I honestly don't know what to do at this point, I have a spare harness for the engine might try to replace the old one with but the car at least ran before I swapped the sensor. When I'm cranking the car, it wants to run but I feel like there is a cut off stopping it? ( I'm also taking apart the rear suspension putting new bushings in, I don't think it would be an issue that would stop the car from starting? Not having the rear abs plugged in currently)
Understood. Do you have an access to the ECU? It would be helpfully to readout the MIL messages and to see what the engine signals like engine speed, MAP, TPS and so on are doing while it cranks, idles and is operated.

Regarding ABS connector, I am not sure. But if I were the engineer, I would demand in the software for the connection plugged in, because it is an safety issue. Just my two cents.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #49
Understood. Do you have an access to the ECU? It would be helpfully to readout the MIL messages and to see what the engine signals like engine speed, MAP, TPS and so on are doing while it cranks, idles and is operated.

Regarding ABS connector, I am not sure. But if I were the engineer, I would demand in the software for the connection plugged in, because it is an safety issue. Just my two cents.
I only have a simple check engine light reader lol. Yeah I think I'm going to finish the suspension overall and see if that fixes it, if not I guess a k pro and k24a2 would fix these issues?
 

·
Arouse the DAMPFHAMMER!
Joined
·
6,266 Posts
I only have a simple check engine light reader lol. Yeah I think I'm going to finish the suspension overall and see if that fixes it, if not I guess a k pro and k24a2 would fix these issues?
Let's find it out. Getting smarter by doing is always a good approach.

You can definitely combine the K24A2 with an KPro and improve performance as well as insight views into the ECU as the KPro makes that door open for you. But the lever arm to solve your engine problem is a huge one 😉.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #51
Let's find it out. Getting smarter by doing is always a good approach.

You can definitely combine the K24A2 with an KPro and improve performance as well as insight views into the ECU as the KPro makes that door open for you. But the lever arm to solve your engine problem is a huge one 😉.
Nothing, still doesn't want to fire up, maybe another new crank sensor is needed? When I try to start it, it is as if the car wants to start, it will sound like it starts rev for half a second and then just die and all you can do then is crank.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #52
Bought a new Denso Crank sensor and nothing. Something seems to be stopping the car from starting, like it wants to start and right before it starts it just dies. My question at this point is that if I buy a k pro and k24a2 will I still have this problem or no?
 

·
Arouse the DAMPFHAMMER!
Joined
·
6,266 Posts
Bought a new Denso Crank sensor and nothing. Something seems to be stopping the car from starting, like it wants to start and right before it starts it just dies. My question at this point is that if I buy a k pro and k24a2 will I still have this problem or no?
I understand your frustration at this point. This is a nerve stretching situation with the start issue. Before I can answer your question, I need to know the exact engine code, the harness part number if not stock to that engine.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #54
I understand your frustration at this point. This is a nerve stretching situation with the start issue. Before I can answer your question, I need to know the exact engine code, the harness part number if not stock to that engine.
Stock engine harness, can't get any codes since the car won't start anymore. If I plug in a reader it can't scan.
 
41 - 59 of 59 Posts
Top