Honda / Acura K20a K24a Engine Forum banner

1 - 20 of 26 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hey I just finish doing my K24a2 swap in my Eg and motor as 1000cc injectors with a stock fuel pump and I’m getting really lean reading on my wideband is idling at 20 a:f way to low could it be that I need a bigger fuel pump cause of my injectors upgrade. ? ! Thanksss
 

·
Registered
Joined
·
97 Posts
Idling lean its unlikely your fuel pump capacity.

Is your fuel pressure reg referenced to manifold vacuum or fixed pressure?

Do you potentially have an exhaust leak giving a false lean reading on your lambda sensor? Where is it located? Do you have the stock sensor hooked up as well to compare readings from?
 

·
Registered
Joined
·
15 Posts
Discussion Starter #4
Well I don’t have a stock 02 sensor I have a aem wideband that’s hooked up and I believe it’s pretty accurate and my fuel regulator the vacuum port is blocked off and I suppose to leave it open ? And my theory is that I need a better fuel pump to meet demands with the high 1000cc injectors
 

·
Registered
Joined
·
97 Posts
The vacuum port needs to be open to atmosphere. Temp fluctuations in the reg with the compensator port sealed off could be causing your pressure's to fluctuate a lot.

You dont need a bigger fuel pump just because your idle is lean. Doesn't matter how big your injectors are, at idle the fuel demand is the same as stock.

20 psi is too low fuel pressure. Stock pressure is 52psi i believe.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #6
Okay cool I took off the vacuum port so the regulator can get air still at 20psi I turn the car on and at first it’s running rich as it’s warming up it leans out all the way to 20 a:f I’m starting to think maybe I need a tune ? And my fuel pressure is still low 🤦🏽‍♂️
 

·
Registered
Joined
·
15 Posts
Discussion Starter #12
Update I been working all week so I haven’t mess with the car but tomorrow I’m off I so I’ll give it a try and adjust the needle on the regulator
 

·
Registered
Joined
·
15 Posts
Discussion Starter #14
Yea bro I already order one just waiting for it to come In the mail reason why I haven’t mess with the car cause I wanna wait till fuel pump comes in and do it all at once and get the the bottom of it but I’ll defiantly keep you guys updated
 

·
Registered
Joined
·
15 Posts
Discussion Starter #15
Hey so here’s is the update on the car I try adjust the needle on the fuel regulator and it does move up but it only went up to 24psi and I max out the regulator so still really low fuel pressure NEED HELP ! I’m gonna pick up a fuel pump later this week and see if that helps
 

·
Registered
Joined
·
15 Posts
Discussion Starter #18
Yea I just talk to my tuner and he said take the fuel filter and fuel line apart make sure it’s not clogged up and make sure fuel pump feed is not lose or anything so I’ll do that tomorrow morning 👍🏽
 

·
Registered
1995 EG Hatch, K20Z3
Joined
·
52 Posts
It does seem like the problem is somewhere upstream of the regulator. Hope the fuel filter or line is indeed the culprit
 

·
Registered
Joined
·
15 Posts
Discussion Starter #20
Hey so update on the low fuel pressure issue today i took all fuel lines apart made sure nothing was clogged up and everything checked out good so I connected everything back up and I prime the car to check for any leaks as I prime the car I walked over to the fuel pressure regulator gauge and started tapping on it maybe it was stuck and BOOM as I’m tapping it the fuel pressure gauge it starts going up to 50psi so it seem like I found the issue which it’s a bad fuel pressure gauge I guess since I had it sitting so long now it tends to get stuck so I’m defiantly gonna go grab a new one ! 👍🏽 Thanks guys for all the help !
 
1 - 20 of 26 Posts
Top