Honda / Acura K20a K24a Engine Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
256 Posts
Discussion Starter · #1 ·
ok so i just had a BDL 70MM Throttle body on my Z3 swap and besides the idle would act up from time to time it also got stuck at times. i decided to switch it out for an OEM k20A-TypeS throttle body with an oem TPS sensor that remained untouched; after installing i noticed my RPMS higher than usual, i drove it around and noticed that my throttle wasnt opening up entirely and then my idle went up from 1300 to 2k rpm. i tried to trouble shoot it but no luck at ALL. now i need help from the experts on here, is there any other mods to support this throttle body needed on my Z3 swap? i have the adapter on it and gasket but the idle is WAY too high and i cannot get it to go down, do i need the throttle bracket Karcepts sells as well as NEW rsx throttle cable? PLEEASEE help me get rid of this!:mad:
 

·
Registered
Joined
·
2,531 Posts
Sounds like the IAC has sat long enough to develop some corrosion and has become "stuck". I have had this issue several times.

Remove the IAC from the TB and spray some WD40 into the passageway and allow it to sit over night. I usually break down the IAC(seperate the mechanical from electronics portion) and spin the rotor with a drill to clean it completely.
 

·
Registered
Joined
·
256 Posts
Discussion Starter · #4 ·
^thanks alot, i will try that when i get home from work. and the WOT opening partially has to be a problem with the cable being adjuster right?
 

·
Registered
Joined
·
1,485 Posts
^^^could be. check then recheck the throttle cable and adjust if necessary. The iacv is a pain in the ass make sure you sorta lube it aswell after cleaning...
 

·
Registered
Joined
·
256 Posts
Discussion Starter · #6 ·
Sounds like the IAC has sat long enough to develop some corrosion and has become "stuck". I have had this issue several times.

Remove the IAC from the TB and spray some WD40 into the passageway and allow it to sit over night. I usually break down the IAC(seperate the mechanical from electronics portion) and spin the rotor with a drill to clean it completely.
where does the iacv go connected to?
 

·
Registered
Joined
·
2,531 Posts
It is attached to the bottom of the TB.
 

·
Registered
Joined
·
256 Posts
Discussion Starter · #9 ·
when i disconnect the tps while car is on it does not act any different, also i think i need a diff throttle bracket because my throttle might be pulled a little
 

·
Registered
Joined
·
2,531 Posts
There should be a connector on it from the wire harness. The tubes are simply for coolant.
 

·
Registered
Joined
·
256 Posts
Discussion Starter · #15 ·
^no i got the typeS bracket on the way and i got a 96cx throttle cable and an rsx-s one on the way to see which one i like better hopefully it fixes my dilema
 
1 - 15 of 15 Posts
Top