Honda / Acura K20a K24a Engine Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
429 Posts
Discussion Starter #1
hey i tried putting my b series fan switch into the spot on top of that coolant thing where the upper radiator hose connects but its to small. how do you other guys connect that switch to it?
 

·
Premium Member
Joined
·
363 Posts
hey i tried putting my b series fan switch into the spot on top of that coolant thing where the upper radiator hose connects but its to small. how do you other guys connect that switch to it?






Which one are you referring to?
 

·
Registered
Joined
·
2,117 Posts
I put it in the rad. myself but I had a rsx one so it had the bung.
The small one in the pic is for the temp gauge,and you will need a reducer fitting for it to fit.
 

·
Registered
Joined
·
429 Posts
Discussion Starter #10
ok i have a rsx radiator too. and it has the switch..i guess im talking bout the coolant sensor temp thing. it that the coolant switch in the picture with the motor? or does it look like the fan swtich
 

·
Registered
Joined
·
2,117 Posts
ok i have a rsx radiator too. and it has the switch..i guess im talking bout the coolant sensor temp thing. it that the coolant switch in the picture with the motor? or does it look like the fan swtich
I am a little lost here??
my coolant temp sensor is in the head.it goes to the rsx harness.
the temp sensor for the gauge is up top like in the pic.
and the fan switch is in the rad.these two are hooked to the conv. harness.
coolant switch=????????
 

·
Registered
Joined
·
142 Posts
If you are running Kpro, Kpro can run your fan without the need of the fan switch so you don't have to cut your hose
 

·
Registered
Joined
·
429 Posts
Discussion Starter #17
who knows........can someone please show me a pic of the fan switch and coolant sensor? so i know what im doing
 

·
Registered
Joined
·
255 Posts
If you have a rsx radiator, the fan switch goes on there. There are 2 coolant sensors when you do a swap. ECT - The one the ecu reads (which is on the white and on the side of the head in the pics), then there's just the extra one for your Cluster (which is circled in the above pic).

The sensor you have from the LS is an ECT not the one needed for your cluster. Once again refer to pic of circled one for what you need.
 
1 - 19 of 19 Posts
Top