Honda / Acura K20a K24a Engine Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Please move post if I posted it in the wrong area I’m new here. What’s up I need help I k24a2 swapped my 07 fa5 am running into issues. I have engine code p1009. I cleaned the vtc solenoid and got a new vtc filter. Tested vtc with 12v and it’s not stuck. I swapped the 50 degree vtc from my k20 and made sure the timing marks were lined up. ( - -) and the bottom crank dot up with the chain link. I also made sure to unlock the vtc gear and torqued it to spec then locked it. And an idle issue where the idle bounces most likely due to me cleaning the throttle body. Anyone give some insite?
 

·
Premium Member
Joined
·
10,420 Posts
You need to learn in the idle. Doubtful it will make a difference. Is the chain stretched?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
I haven’t done that yet I heard that I need to recalibrate the tps with a scan tool. I just bought one and waiting. Also I’m waiting for the new chain, guides and tensioner to come in. I’m leaning towards the chain being stretched as well
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
What’s up everybody I think I figured the problem out I had a broken pulse plate dowel pin on the exhaust side 🤦‍♂️.
When aligning the cam gears I saw that the cam locking pins on the back of the cams were off so I loosened the hex bolt and I was able to spin the plate by hand. Since the plate was off I believe it was Causing the ecu to think it’s stuck in advanced. I’m surprised I didn’t get a cam position code. Wish me luck putting everything back with new plate!!!!
102967
 
1 - 6 of 6 Posts
Top