Honda / Acura K20a K24a Engine Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
I have been having issues with my engine since the swap. For a while it was burning through ignition coils like crazy, but that may have been due to the coils being eBay brand. Now it isn't idling very well.

After warming up it will do things like dip very low or surge very high when stopped. It is worse when driving and then stopping at a light. I have tried adjusting the idle cycle valve adjustment above and below the center mark but it does it regardless.

I have read several articles on this site and others regarding the MAP sensor, TPS, IACV, etc. but I cannot determine what is the problem. You will see in the attached video link that kpro shows readings from the MAP and TPS and they seem to increase and decrease consistently with revving. Therefore I am thinking it is the IACV, but I would appreciate any other thoughts advice that anyone can offer.

Technical Specs:
Remanufactured K20A2 fresh from dealer
410cc RDX injectors
PRB intake manifold
PRB ecu with kpro
Injen ram intake
HPR headers
Apexi axle-back
All other bolt on parts are from the A3 including the valve cover

Video showing idle dip including kpro readout, I could not include the rpm surge because like I said it happens at red lights and does not happen every time and I generally don't have the time to whip out my phone.

https://www.youtube.com/watch?v=fa4Vv3iodhM&feature=youtube_gdata_player
 

·
Registered
Joined
·
25 Posts
Is your throttle receiving coolant? I know when I cut off the coolant to the throttle it started doing that. Also there are lots of people who only needed to clean the iacv with brake cleaner and it worked fine after that. I would start with cleaning the tb.
 
1 - 2 of 2 Posts
Top