Honda / Acura K20a K24a Engine Forum banner

EP2 K Swap. Getting fuel, spark, cranking but no start

2866 Views 16 Replies 2 Participants Last post by  Lotus
I've been having problems with my k swap for 2 months now. Started off with swapping immobiliser and using a k tuned conversion harness, it would start and run but dies when you give it throttle. Moved on to swapping out the whole dash harness and the engine bay harness to rule out any wiring difference between the EP2 and EP3 as I needed to swap the dash fusebox to get it to start. Didn't fix it. Ended up buying a new o2 sensor, cam sensors, crank pos sensor, knock sensor was changed before the engine was swapped in, inertia switch was checked, getting fuel. Still no difference. After that I ended up buying a K Pro same problem car would start but rough idle and can't give it throttle. Changed the tps sensor, checked the throttle body didn't have leaks, all the sensors on the throttle body is new. Calibrated the TPS in K Pro. Same problem. Bought an AEM wideband wired it pos to cig lighter, ground to chassis, analog input to 0 on the K Pro ground to the last pin on the end clearly labelled ground. Wideband reads fine in K Pro however the gauge will be off by 2:1 K Pro reading 15:1 for example gauge is reading 17:1 in K Pro it states if you have to input a negative voltage offset then the ground needs checked which I done even tried the chassis under the dash and the intake manifold. MAP sensor is reading -24 psi crank it goes to -2 psi and stays there. So what I'm dealing with right now is a crank no start. Made sure it was getting spark took a plug out grounded it cranked and seen a strong spark, plugs are also wet so it's getting fuel. Took the fuel rail off and aimed it away from the engine bay to watch what the spray pattern is like to make sure it's not dripping spraying just fine not really a mist of fuel not an expert with injectors and how the spray pattern should look. When cranking the cam position reads 0 but jumps to 107 when I stop cranking. Before this I made sure the timing was fine and both cams line up. Timing chain, tensioner and guides are all brand new. The injector pulse is around 30 ms which doesn't seem right as it's been around 22ms before when it would start and run confirmed it by looking at other people's datalogs on this forum and Hondata's forum. Also engine grounds are all new wiring. Ground from the valve cover to chassis, idler bracket to radiator support, gearbox to chassis. Moved the injector grounds which I'm sure is the ground for the ECU is grounded to the side of the head just next to the cam sensors could this cause interference I'm not sure. I've been working on cars for 6 years I'm no expert but I did manage to do this whole project by myself swapping engines over the whole lot.

What else should I check or does anyone know what this problem is because I'm really stumped it's getting on my nerves I don't want to give up I've put thousands into this project. Clean Type R's are hard to come by in the UK unless your willing to spend well over 5k, was let down when I bought my Type R to find it all rotten under the side skirts and bumpers etc instant MOT fail.
See less See more
1 - 8 of 17 Posts
MAP sensor should read about ambient pressure with ignition on lowering into decent vacuum while cranking. As you indicate negative values, it seems you set it to show 0 PSI at ambient and some -12 to -10 or so while cranking. Someone in the US may relate to those US units.
For the UK, I‘d set it to mbar absolute as this is what Honda themself use.

If you ever swap the TPS and MAP sensor plug by accident, it destroy the MAP sensor.

If you use an analog input on the KPro, you need to complete a conversion table voltage to lambda or select the right one from their menu.

Also if plugs are wet, they easily foul. You might have drowned our engine.
Dry the plugs and crank with injectors disconnected and plugs removed WOT for some 30 seconds.
At worst you need new plugs.
yes, if it fires way rich, a thin layer of soot forms on the plugs as the spark essentially cokes the condensed fuel layer on the plugs. Once this has happend, you see a spark, but it is weaker and may fail to fire the engine. fine tipped iridium plugs are more resistant to these processes, but still wet plugs can prevent the engine from firing at all.
TPS and MAP can be swapped with the stock harness. I know as it happend to me.
CAM sensors also pugged in right?
No error codes?

Best to put on a fresh base map, check for sensor data consistency (all values plausible, ECT, IAT, TPS, MAP) , purge the engine and get it to idle. Then go from there.
on fast glance into your data logs it seems you have a huge air leak.
MAP shows ambient, but it does not change when cranking. -> leak.
if the MAP sensor would show ambient as being in defective, the engine would fire, but stall again within a second or two. This is typical for failed MAP sensors.

The throttle body needs to be completely closed.
In the longer log with it idling, it also showed way too high MAP with it only once drping when revs increase. TPS was also not calibrated or hanging as it shows 17%, sometimes 19%. After a blip, it sometimes returns to a slightly different value indicating mechanical issues.

Could it be your throttle hangs or the cable is too short and therefore TPS correctly showed 17% to 19% and now you only recalibrated it to show 0% while it still being open?
See less See more
can you check that your MAP sensor works by sucking on it while sucking on it or checking the values on screen?
MAP drops only by 10 mbar upon cranking. Seems low to me. ECU asks for 5% injector and few deg ignition advance. It seems all good.

Are you sure you got fuel pressure?

If you suck on the MAP sensor inlet, pressure reading has to drop some 100-300mbar. If not, it is defective.
mat 3 bar fuelpressure, you need to see some sort of spray or in case of pencil beam injectors (these would be some aftermarket special injectors) a fine line of fuel exiting with some power.

without fuel pressure, it won‘t start
Then you likely have a loom issue.
Measure the line from the signal pin of the map sensor to the ECU plug.
is the MAP sensor properly configured in the ECU? Is there a map uploaded on the ECU?
I suggest you follow the RSX manual checking the MAP sensor.
Do you have the RSX service manual?
the MAP sensor needs to work. Either the sensor is broken, the wiring isn’t right or the ECU is damaged.
even it it would show a constant 1000mbar, it should fire before stopping within a second or two as MAP drops.
Can you 100% confirm that the TB is closed?

Next is your fuel pressure. a little drip is not sufficient upon cranking. You might spray some brake cleaner into the inlet and try to start it. if you get some bangs, you likely lack fuel for yet unknown reasons.
1 - 8 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.