Honda / Acura K20a K24a Engine Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I finished up building my engine. Forged internals on the block and Supertech valves, springs and retainers with Skunk2 stage 2 cams on K20a2 head.
Quickly noticed that after exactly 1700 rpm it starts making a horrible noise coming from the head, something like a rattle. I can't be neither timing chain nor the tensioner because they're both brand new. Disassembled the head. Checked the rocker arms, pins and springs and they looked fine. Only thing I noticed is that something is hitting both 5th intake and 5th exhaust valve retainers and I suppose that's what's making the noise. The exhaust valve retainer has a lot more wear. Don't know if it's the cams or the rockers hiting it somehow, but neither have any type of excessive wear.
Has anybody had a similar problem, any ideas on how to fix it?
Any help would be appreciated.
Thanks.
 

Attachments

·
Registered
Joined
·
1,023 Posts
LMA's maybe ?
 

·
Arouse the DAMPFHAMMER!
Joined
·
7,722 Posts
Has anybody had a similar problem, any ideas on how to fix it?
The rocker arms are the only part which are in contact with the valve stem over the adjustable screw to set the valve lash. But nothing should contact the valve retainers.

Edit: I mean from above, while from below the valve spring presses the retainer :)

If there are marks, check for anything loosen in under the valvecover. Check the bolts for the 5th cam tower and there torque...and so on.

Markus
 
1 - 6 of 6 Posts
Top