Honda / Acura K20a K24a Engine Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
84 Posts
Discussion Starter #1
hey guys, im having clutch problems with my eg.
93' EG hatch
k20a 6spd
i have a steel braided line with an fittings for my clutch. every so often i loose all my clutch fluid. this happened twice to me. after the first i cut the line a lil bit thinking maybe i had a hole in the line or something. that wasnt it, it still leaked all out. with that second time i switched out the clutch slave with a brand new one, and yet again it happened. all this happening within a month time span. and jus the other day i felt it loosing pressure again and sure enough i was low on fluid and had to fill it again. anyone know about this bein a frequent problem? and also, should i jus swap out the hole line?
 

·
Registered
Joined
·
1,026 Posts
Look under you dash and see if your master is leaking. Look at the clutch pedal and see if its wet.
 

·
Registered
Joined
·
1,026 Posts
Any updates?
 

·
Registered
Joined
·
84 Posts
Discussion Starter #5
hey guys, as an update, i took the car out tonight. checked the resivour before driving and it was low so i filled it up. i did check the pedal, the medal leg part had some wetness to it as well as the black piece that goes into the firewall, and also i felt some wetness from the bottom of my an fitting that goes into the slave. is it possible the line and the master need to be replaced?
 

·
Super Moderator
Joined
·
26,613 Posts
Yes. It needs replacing.
 
1 - 6 of 6 Posts
Top