Honda / Acura K20a K24a Engine Forum banner
1 - 6 of 6 Posts

·
Registered
92 EG k24z3 swap
Joined
·
126 Posts
Discussion Starter · #1 ·
Hello all,

Still trying to figure out my slow crank.
Rewired the charge harness and came across this connector
can anyone give me more info about the connector from the rsx harness
Glove Automotive lighting Motor vehicle Helmet Sports gear



the second photo is where I found my knock sensor
I'm unsure of where to pin the ect and knock sensor
Thoughts?




Automotive tire Automotive fuel system Hood Motor vehicle Automotive exterior
 

·
Registered
Lotus Elise K20A2
Joined
·
1,375 Posts
if the starter activates and engage the flywheel the “little” cabling stuff works as intended. Their function is more or less digital.

You need to check the big stuff. I know one chap that had a broken cable from the fuse box/battery to the starter motor. Not visible, but intermittently the starter would “clack”, but not spin. Wiggle on the cable and most of the time it worked again. The fix was a new 25mm2 starter cable he build.
I need him to take the insulation of the OEM cable and take pictures.
 

·
Registered
92 EG k24z3 swap
Joined
·
126 Posts
Discussion Starter · #5 ·
You need to check the big stuff

Good F'ng call

Tightened the loose ground cable at battery, scraped away paint to expose more metal,
added another transmission ground and
She starts!!!

Im shaking

She loud

now to figure out why it revs to 2000 then stalls?
Deleted iacv perhaps?


This has been the puzzle that keeps giving

Lotus, thank you for taking your time to help me along,
I couldn't have done it without your help
 

·
Registered
Lotus Elise K20A2
Joined
·
1,375 Posts
if it stalls within seconds, you MAP sensor may be defective.
If you have a programmable ECU or an OBD reader, check if the TPS and the MAP sensor all read plausible values. TPS should read 0% and 100% when fully open. MAP should read atmospheric pressure within ignition on, but engine not running and drop to about 300 mbar absolute pressure when idling.
MAP sensor dies if you accidentally swap the black TPS and the blue MAP connector. It then reads a fixed value leading to the car stalling from running overly rich as MAP drops with the engine picking up, but the ECU not removing fuel accordingly.
 
1 - 6 of 6 Posts
Top