Honda / Acura K20a K24a Engine Forum banner
1 - 6 of 6 Posts

·
Registered
1996 Acura Integra K20a2 swap 5 Speed, RBC Intake, Ktuned header, AEM fuel pump , -6AN lines
Joined
·
47 Posts
Discussion Starter · #1 ·
I have bad voltage fluctuation from startup and while driving Hondata kpro reads 12.00 - 13.88/13.99 voltage and it constantly goes up-down. Have all recommended engine grounds and charge harness right. The battery is new and the alternator.
1. Battery ground to strut tower and in stock location.
2. Ground wire from the front of transmission to driver lower frame rail
3. Engine harness ground is on the center valve cover bolt
4. Timing cover ground to passenger side strut tower.

2003 RSX k20a2 engine and engine harness
2002 Civic Si 5 speed trans
Phanectric k-swap conversion harness
 

Attachments

·
Registered
Joined
·
556 Posts
Are you having any negative effects from this?

Mine fluctuates voltage a lot from 12.4-14.2 volts. I assumed this was normal variance from the ecu ELD control doing what it needs to do. I was worried for a while but noticed my battery maintains good charge levels so haven't thought much of it since then.
 

·
Registered
1996 Acura Integra K20a2 swap 5 Speed, RBC Intake, Ktuned header, AEM fuel pump , -6AN lines
Joined
·
47 Posts
Discussion Starter · #3 ·
Are you having any negative effects from this?

Mine fluctuates voltage a lot from 12.4-14.2 volts. I assumed this was normal variance from the ecu ELD control doing what it needs to do. I was worried for a while but noticed my battery maintains good charge levels so haven't thought much of it since then.
My car only gets driven in summer and has spent most of its life parked sucks and had some bugs and bad sensors but this only issue left i was gonna try to figure out. have you had any issues or negative problems. Ever try disabling the ELD?
Yeah, it's been like this since day one I even rewired the conversion harness and triple-checked everything a couple of times. The only part not replaced is the alternator but did have it tested and is fine. No negative problems though.
I rarely see ant voltage in 14s highest is like 13.88-13.96volts that I saw in my data log.

What car setup you have man?
 

·
Registered
Joined
·
556 Posts
I have an ef3 civic hatch with k20a euro r running gear in it. Club car, not road legal. I have had no negative issues with the voltage fluctuations over the last 2 years of racing it. But i use a battery charger to maintain between events.
 

·
Registered
1996 Acura Integra K20a2 swap 5 Speed, RBC Intake, Ktuned header, AEM fuel pump , -6AN lines
Joined
·
47 Posts
Discussion Starter · #5 ·
I have an ef3 civic hatch with k20a euro r running gear in it. Club car, not road legal. I have had no negative issues with the voltage fluctuations over the last 2 years of racing it. But i use a battery charger to maintain between events.
club car car I want do that some day. I actually have same engine I'm stuff it in rsx believe that's what mine is its stamped K20A and has the valve cover thats little different
See pic that same engine?
Where you from north east region?
 

Attachments

·
Registered
Joined
·
556 Posts
No that's a different engine to mine. Mine is a factory red valve cover and has more in common with the k24a2 than the k20. Mine had factory balance shaft oil pump and k24 style water pump housing and water outlets.

In in New zealand. We have a lot of Japanese import models here.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top