Honda / Acura K20a K24a Engine Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
2,048 Posts
Discussion Starter · #1 ·
starts fine but wont stay running.
like an idiot i put several parts on at one time instead of 1 at a time.
was completely stock with 228k. rebuilt trans
PARTS:
put on short ram intake(tried MAF both directions)
header and full sudo exhaust no cat.
change plugs.DENSO PK22PR11 not sure if these are right
deleted iaa
removed evap.
relocated battery to the back(done several times) no issues.
TSX throttle body with thermo gasket(put SI TB back on, no difference)
TB coolant bypass

so i cant get the codes checked. i don't have flashpro(which should have been first step but its the next purchase)
it starts. and runs if you feather throttle.
i bled the coolant already feathering throttle. up to full temp.
new plugs show its very rich. super black.
I'm doubting intake and exhaust are causing this. COOLANT ISSUE? i searched all the DIYS. i did it to the T. they say run the car to let it relearn the idle???
any ideas?
 

·
Registered
Joined
·
2,048 Posts
Discussion Starter · #2 ·
i put the battery back up front. I put the stock intake back on. I put the old plugs back in same issue.

I would love to just do the idle relearn but it won't stay running it sounds like a Subaru but you when you rev it up to 4- 5000 RPMs it sounds strong and it sounds even with no shaking or Miss
 

·
Registered
Joined
·
56 Posts
I had thr same issue. With my tsx is this dbw
Just so u know my problem was a wet plug on crank sensor n then the crank sensor turn out to.b E bad
 

·
Registered
Joined
·
2,048 Posts
Discussion Starter · #4 ·
Yeah the 2007 SI its DBW. The plug is dry.
I don't know if the sensors would go bad overnight. I had done all these things and one of them is causing an issue.
So tomorrow I'll try putting the EVAP lines back on. undoing the coolant bypass. And putting on the idle air assist sensor and line again
 

·
Registered
Joined
·
56 Posts
Well what ur telling me it sounded like my cranksensor i had to press slowly to acelerate n keep it on or it ran shut off by itself
 

·
Registered
Joined
·
2,048 Posts
Discussion Starter · #6 ·
was it throwing a code for it? I think if I get the codes checked it would give me my answer but I don't have a code scanner and I can't drive it somewhere
 
1 - 9 of 9 Posts
Top