Honda / Acura K20a K24a Engine Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter #1
Hi folks, I'm currently swapping a k24a4 from a 2004 Honda Accord 5MT into a VW Golf and am stuck trying to find out what I should hook up to the C251 connector which splits off the engine harness before everything goes into the ECU.

Here's where it should be located at in a 2004 Accord:
101464


I've got the following diagram:
101465

I'm working off the L4 side since I assume that means 4 cylinder.
Here's my thoughts per pin so far
Known:
  • Pin 8 appears to be the backup light switch from the transmission
  • Pin 12 is switched 12 volt
Unknown
  • Pin 6 is the IG ACG fuse which may control something with the fuel pump? Is this needed if my fuel pump isn't controlled by the ECU?
  • Pin 7 is the IG Meter fuse which I think is the dash? I probably won't need this
  • Pin 9 I'm assuming is an output to the dash
  • Pin 10 Boy I have no idea what this is for. Maybe fuel injectors?
  • Pin 11 I don't think I'll need this as I have a manual trans?
  • Pin 13 I have no idea the circuit behind this. I bet this is whats causing my no spark condition but who knows.
My main issue at the moment is that I'm getting no spark. I assume this is due to pin 13, but could be related to pin 10?

Any help or advice would be greatly appreciated!
 

·
Registered
Joined
·
36 Posts
Discussion Starter #2
So I think I found out what to do with Pin 13. It appears it should get 12v when the ECU energizes the main relay. If you all know what to do with the others I'm all ears!
101471
 

·
Registered
Joined
·
36 Posts
Discussion Starter #3
Bump on this I've got another question about this connector and the Air Fuel Sensor on bank 1. It has 4 wires and 2 of them complete a circuit for the a/f sensor heater.

Those two wires are a green wire that goes to the A connector on pin 10 and a white/black wire that goes to the C251 connector on pin 10. The listing for the ECU connector says that you should read 12v at position two there but I'm not sure the its sending 12v or if its receiving 12v. I guess what I'm asking is should I hook the white/black wire that goes to the C251 connector to 12v?
 

·
Registered
Joined
·
36 Posts
Discussion Starter #4
If you hook pin 10 on the C251 connector to 12v it works fine and you'll actually start to get o2 readings! Just a heads up for future folks.
 
1 - 4 of 4 Posts
Top