Weak crank. - K20A.org .:. The K Series Source . Honda / Acura K20a k24a Engine Forum
Reply
 
Thread Tools
Old 07-08-2019, 11:33 AM   #1
Intra focus
New Member
 
Join Date: Mar 2012
Posts: 73
Default

I have a 93 del sol with a K20z3 engine. Running Kpro. Car started fine but I pulled out the harness to tuck it and just clean it up. Now when I go to start it, it cranks super weak like the battery is almost dead but I have tried several good batteries. I will do voltage drop test and starter voltage test just thought I would throw this up for any suggestions. Thank you.

Last edited by Intra focus; 07-08-2019 at 01:32 PM..
Intra focus is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-08-2019, 03:46 PM   #2
clumbz
K20a.org Basic User
 
Join Date: Jul 2010
Posts: 160
Default

My assumption for the weak cranking I would have to say lack of grounding.. but definitely do all that you have planned on already and cross off as you go. Good luck 🤝 keep us posted
clumbz is offline   Reply With Quote Quick reply to this message
Old 07-08-2019, 06:54 PM   #3
jonnyfrancais
New Member
 
Join Date: Nov 2017
Posts: 65
Default Re: Weak crank.

could be the starter slowly dying but its not likely if it ran fine before the wiring cleanup. I'd also say its probably a ground, make sure they are in the correct location and that they contact bare metal on the car
jonnyfrancais is offline   Reply With Quote Quick reply to this message
 
Old 07-09-2019, 08:42 AM   #4
Intra focus
New Member
 
Join Date: Mar 2012
Posts: 73
Default

Thanks guys. Glad to see the forum is alive. Sadly my project has sat since the first start back in 2012. I had a kid and life got in the way but I'm making goof money now and have free time so it's time to finish her up and just wanted to fix a few half ass things I did on the initial build. I took out the entire harness just to check that there were no loose wires or anything. I will put that back in and check all my grounds although I have the wireworx grounding kit and that was not touched as part of the work but I will double check them for sure. I am going to do some voltage test after work this week.
Intra focus is offline   Reply With Quote Quick reply to this message
Old 07-11-2019, 08:19 PM   #5
Zedicous
New Member
 
Join Date: Apr 2008
Location: Slidell, LA.
Posts: 16
Default Re: Weak crank.

Being an IT guy for decades, when things were running smoothly and something changed, i would go back to the last thing i did and usually find it. Time to play with wires and look for cuts, grounds, etc.
Zedicous is offline   Reply With Quote Quick reply to this message
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the K20A.org .:. The K Series Source . Honda / Acura K20a k24a Engine Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools

Posting Rules
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -8. The time now is 08:43 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.