EP3 with K20A2 idling issues - K20A.org .:. The K Series Source . Honda / Acura K20a k24a Engine Forum
Reply
 
Thread Tools
Old 10-27-2013, 04:17 PM   #1
mooky_stank
New Member
 
Join Date: Oct 2009
Posts: 25
Default EP3 with K20A2 idling issues

I have been having issues with my engine since the swap. For a while it was burning through ignition coils like crazy, but that may have been due to the coils being eBay brand. Now it isn't idling very well.

After warming up it will do things like dip very low or surge very high when stopped. It is worse when driving and then stopping at a light. I have tried adjusting the idle cycle valve adjustment above and below the center mark but it does it regardless.

I have read several articles on this site and others regarding the MAP sensor, TPS, IACV, etc. but I cannot determine what is the problem. You will see in the attached video link that kpro shows readings from the MAP and TPS and they seem to increase and decrease consistently with revving. Therefore I am thinking it is the IACV, but I would appreciate any other thoughts advice that anyone can offer.

Technical Specs:
Remanufactured K20A2 fresh from dealer
410cc RDX injectors
PRB intake manifold
PRB ecu with kpro
Injen ram intake
HPR headers
Apexi axle-back
All other bolt on parts are from the A3 including the valve cover

Video showing idle dip including kpro readout, I could not include the rpm surge because like I said it happens at red lights and does not happen every time and I generally don't have the time to whip out my phone.

https://www.youtube.com/watch?v=fa4V...e_gdata_player
mooky_stank is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-12-2013, 06:38 AM   #2
Danito321
New Member
 
Join Date: Nov 2012
Posts: 25
Default Re: EP3 with K20A2 idling issues

Is your throttle receiving coolant? I know when I cut off the coolant to the throttle it started doing that. Also there are lots of people who only needed to clean the iacv with brake cleaner and it worked fine after that. I would start with cleaning the tb.
Danito321 is offline   Reply With Quote Quick reply to this message
Reply

Bookmarks

Tags
ep3, idle, k20a2, problem, swap

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the K20A.org .:. The K Series Source . Honda / Acura K20a k24a Engine Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -8. The time now is 10:07 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.